problems with Edit>Find>Search_Messages

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
11 years ago
9 years ago

People

(Reporter: nobler, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-10-15)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 2.0.0.14

1.  Message field is "Sender" but search searches on "from"

2.  Has trouble with search terms.  I'm looking for mail from my 
boss named "Milopoulos".  I search on From = "milo", nothing comes 
up.  I search on From="milo*", nothing comes up.  I have to search
on From="milopoulos", ie, the whole word, to get a match.


Reproducible: Always

Steps to Reproduce:
1.  see above
2.
3.
Actual Results:  
see above

Expected Results:  
Netscape 4.78 (which I still have on an old machine at home) is a bit more forgiving.

You either need to have a system that is more forgiving (translates any search string into "*string*" or give some rules on how to use wildcards in searches.
> 1.  Message field is "Sender" but search searches on "from"

Yes for thunderbird3, the column has been changed to From to avoid confusion with the "Sender" header.

The star notation in search isn't supported (AFAIK). The "milo" search should match though. Is this a problem for other addresses too?
Version: unspecified → 2.0

Comment 2

11 years ago
Created attachment 325183 [details]
search.png

I wish there is option for wildcard character and RegExp in every search.
But most of our issues can be solved by current UI

see attachment, it is from "version 3.0a2pre (2008060803)" 
if this solves your problem please mark the bug as WORKSFORME
else let us know the issue.

List of search conditions for "From" field are
* contains 
* doesnt contains 
* is
* isnt
* begins with
* ends with
* is in my address book
* isnt in my address book

Updated

10 years ago
Component: General → Search
Product: Thunderbird → MailNews Core
QA Contact: general → search
Version: 2.0 → 1.8 Branch
Bob ...

(In reply to comment #1)
> The "milo" search should match though. Is this a problem for other addresses too?
Whiteboard: closeme 2009-10-15
RESO INCO due to lack of response to last comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.