Mozilla crashes in createEvent(...) method

VERIFIED FIXED

Status

Core Graveyard
Java APIs for DOM
P3
normal
VERIFIED FIXED
18 years ago
6 years ago

People

(Reporter: Michail Romanov, Assigned: Ashu Kulkarni)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview Description: 
Mozilla crashes in createEvent(...) method of DocumentImpl class.

Steps to Reproduce: 
Run JavaDOM API org.mozilla.dom.test.DocumentImpl_createEvent_String_1 testcase.

Actual Results: 
Mozilla crashes.

Expected Results: 
Method should work ok.

Build Date & Platform Bug Found: 
06/20/2000

Additional Information: 
Actually Mozilla crashes not in JavaDOM but in the constructor of nsDOMEvent 
class in layout/events/src/nsDOMEvent.cpp file line #88 (aEvent parameter is 
NULL):
 86   mTextRange = nsnull;
 87 
 88   if (aEvent->eventStructType == NS_TEXT_EVENT) {
          ^^^^^^^^^^^^^^^^^^^^^^^

The call stack is the following:

nsDOMEvent::nsDOMEvent(nsIPresContext * 0x0b03ccb0, nsEvent * 0x00000000, const 
nsString & {...}) line 88 + 5 bytes
NS_NewDOMUIEvent(nsIDOMEvent * * 0x0012f96c, nsIPresContext * 0x0b03ccb0, const 
nsString & {...}, nsEvent * 0x00000000) line 1112 + 39 bytes
nsEventListenerManager::CreateEvent(nsIPresContext * 0x0b03ccb0, nsEvent * 
0x00000000, const nsString & {...}, nsIDOMEvent * * 0x0012f96c) line 1603 + 21 
bytes
nsDocument::CreateEvent(nsDocument * const 0x0b03a9fc, const nsString & {...}, 
nsIDOMEvent * * 0x0012f96c) line 3006 + 41 bytes
Java_org_mozilla_dom_DocumentImpl_createEvent(JNIEnv_ * 0x00ac1340, _jobject * 
0x0012f9a8, _jstring * 0x00ab77cc) line 660 + 20 bytes
JVM! 503abfea()
JVM! 503a6436()
JVM! 503d4df8()
03a01620()
00bbad40()

Comment 1

18 years ago
Add crash keyword to open crashers.
Keywords: crash

Comment 2

18 years ago
I believe this is a duplicate of bug 25889 (for which joki may have a fix). 
Marking dependency for now, but mark as a dup if these bugs are one and 
the same. 
Depends on: 25889

Updated

18 years ago
No longer depends on: 25889

Comment 3

18 years ago
aargh! bugzilla. Adding back that dependency.
Depends on: 25889

Comment 4

18 years ago
reassigning to denis, the real owner of java dom
Assignee: akhil.arora → sdv
I just marked the dependency bug as fixed, because there is an implementation
for it and it does not even crash (gasp!) doing it. However, I have no idea how
to test this Java stuff... Please test and see how it goes. It is quite possible
that joki has made a fix for this specific crash, but it hasn't landed yet.
Watch for a large checkin by saari@netscape.com or heikki@netscape.com and see
how it goes after that (assuming there is a crasher right now).

Comment 6

17 years ago
hopefully george will try to find a new owner for this bug
Assignee: sdv → drapeau
(Assignee)

Comment 7

17 years ago
I cannot reproduce this Bug with Netscape 6.0 or Mozilla Trunk codebase. Could 
the Bug reporter pls verify.
_Ashu

Comment 8

17 years ago
Ashu is taking ownership of JavaDOM bugs.  Re-assigning to him.
Assignee: drapeau → ashuk
(Assignee)

Comment 9

17 years ago
This bug was a duplicate of 25889 which has been fixed. I am unable to reproduce
this Bug using JavaDOM with the Mozilla trunk. I am closing this bug.
Alexei/Michail, pls verify using the JavaDOM test-suite.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
Looks like it isn't reproduced. 

Comment 11

17 years ago
Verified according to Vladimir's info
Status: RESOLVED → VERIFIED
Component: Java APIs for DOM → Java APIs for DOM
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.