Closed Bug 438275 Opened 13 years ago Closed 13 years ago

Command-left and command-right (Mac equiv of home and end) do not work in Gmail Compose

Categories

(Firefox :: Shell Integration, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 341886

People

(Reporter: josh, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Command-left and command right should behave exactly like "home" and "end" do in windows. Take you to the beginning and end of a line. It seems there's some sort of hack/flag in firefox that disables the "back / forward" behaviour incorrectly assigned to these keystrokes while editing a keystroke, but whatever it is, it is incompatible with Gmail.

Reproducible: Always

Steps to Reproduce:
1. Reply or compose a new message in gmail
2. Hit command-right, nothing happens
3. Hit command-left, either nothing happens or gmail asks if you're sure you want to leave the page (back button behaviour)
Actual Results:  
Either nothing happens at all, or the back-button behaviour is triggered (happens fairly rarely)

Expected Results:  
Same as "home" and "end" on Windows.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 341886
You need to log in before you can comment on or make changes to this bug.