Detach sometimes detaches wrong file

RESOLVED DUPLICATE of bug 533921

Status

--
critical
RESOLVED DUPLICATE of bug 533921
11 years ago
7 years ago

People

(Reporter: mitra_lists, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9) Gecko/2008053008 Firefox/3.0
Build Identifier: version 3.0a2pre (2008060803)

Sometimes when I detach a file, it saves an empty copy of a different file.  Its intermittent, and the filename used for the different file was - on the most recent occasion - the same as a file I'd opened earlier. 

Reproducible: Sometimes

Steps to Reproduce:
1.Open message
2.Ctrl-click attached file / Detach
3.Choose location,
4.Look in that location - file isn't there, but another file is (sometimes 0k)



This is intermittent, but I've seen it multiple times.

Once it has happened, then it will repeat consistently on trying to re-detach the same file. 

If I close TB and re-open it, then I can detach the same file without any problems.
(Reporter)

Comment 1

11 years ago
This bug is still in 3.0b1pre (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/2008080300 Shredder/3.0b1pre) 

Its pretty bad - caused data loss this time, as the reuse of a previous filename meant it detached a zero byte file over something else important. 

This is bad enough (because of the data loss) that if this wasn't a beta I would have dumped it and gone back to another mail program . 
(Reporter)

Updated

10 years ago
Hardware: PowerPC → All
(Reporter)

Updated

10 years ago
Keywords: dataloss
(Reporter)

Comment 2

10 years ago
Created attachment 354003 [details]
Screen shot showing mismatched dialog and attachment name

I've attached a screen capture, clearly showing an attempt to detach the wrong file - notice the dialog box at the top, and the completely different attachment name at the bottom.   The name given (ATT00038.htm) was the name of the last file detached (successfully).
(Reporter)

Comment 3

10 years ago
Just to clarify, if I'd hit "OK" in response to this dialogue it would have overwritten the previous ATT00038.htm file with a zero-byte file causing dataloss of that file.
Any particular message it happens with? Attach a copy as .eml if it's reproducible.
(Reporter)

Comment 5

10 years ago
It doesn't seem to be specific to a message, but to be a state that Shredder gets into, i.e. if I exit and reload Shredder it works. 

- Mitra
Severity: normal → critical
Mitra, can you reproduce in final release?
(Reporter)

Comment 7

9 years ago
I'm running (almost) nightly updates - currently Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091212 Shredder/3.0.1pre and I've seen it recently (within last week or so). 

Not sure what "final release is" but happy to switch if that is more recent than the nightlies (send URL)
Mitra, 
Can you still reproduce?

similar bugs
 Bug 534850 -  Confusing detach file - select a file from another message then r-click in another detaches wrong file
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader
(Reporter)

Comment 9

9 years ago
Yes - it has been happening even quite recently.

If I remember I'll post the release number here next time I see it.

- Mitra
(Reporter)

Comment 10

9 years ago
Just saw it again.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20100122 Shredder/3.0.2pre
This looks very much like an instance of bug 533921, which was fixed some months after comment 10, so we can safely close this as a duplicate. Furthermore, lots of more recent changes by Jim to the attachment pane (xbl bindings etc.), so anything which still occurs after that probably deserves a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533921
(Reporter)

Comment 12

7 years ago
I haven't seen this bug for quite a while.
You need to log in before you can comment on or make changes to this bug.