row dividers not diaplayed in table

VERIFIED DUPLICATE of bug 45055

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 45055
18 years ago
17 years ago

People

(Reporter: Dave, Assigned: waqar)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Overview Description: 

Related to bug 43706? (also about displaying nested tables).

The above URL has a table showing unique hits to a web page. Mozilla seems, for
the most part, to only show every other row divider in this table while IE 5.01
and NS 4.7 display the table correctly.

Sample html:

</TABLE></TD></TR></TABLE><P>
<TABLE cellpadding=10 height=2% align=left><TR><TD> </TD></TR></TABLE><TABLE
border=0 cellpadding=1><TR><TD bgcolor="#000000"><TABLE cellpadding=3 border=0
cellspacing=1><TR><TD bgcolor=white colspan=4><TABLE cellpadding=5 border=0
width=100%><TR><TD><FONT color=000000 face=arial size=4> <B>Last 20
Visitors</TD><TD align=right><FONT color=dddddd face=arial size=4><B>Unique
Visitors</FONT></TD></TR></TABLE></TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;23
May, Tue, 14:28:41&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;worf.qntm.com&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 95&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;27
May, Sat, 14:25:53&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;210.70.55.243&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;Netscape
3&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Other&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;01
Jun, Thu, 11:12:02&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;192.231.71.108&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;Netscape
4&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 95&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;05
Jun, Mon, 01:12:22&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;192.231.71.108&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;Netscape
4&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 95&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;06
Jun, Tue, 15:09:41&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;192.239.216.99&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 95&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;12
Jun, Mon, 22:10:05&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;204.198.23.88&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;Netscape
4&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 95&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;15
Jun, Thu, 10:19:35&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;168.99.101.4&#160;&#160;</TD><TD bgcolor=ffffdd
align=right><FONT face=arial size=2><B>&#160;&#160;MSIE 5&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;Windows
98&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;17
Jun, Sat, 17:41:29&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;spider-wd013.proxy.aol.com&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 98&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;19
Jun, Mon, 14:57:11&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;cdm-24-198.tca.net&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 98&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;19
Jun, Mon, 22:55:03&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;pxy-hst-12.tandem.com&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows NT&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;20
Jun, Tue, 09:08:42&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;192.239.216.99&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 95&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;21
Jun, Wed, 12:07:57&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;159.98.137.118&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;Netscape
4&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Linux 2&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;24
Jun, Sat, 20:21:23&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial
size=2><B>&#160;&#160;ip24.miami29.fl.pub-ip.psi.net&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 98&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;15
Jun, Thu, 10:19:35&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;168.99.101.4&#160;&#160;</TD><TD bgcolor=ffffdd
align=right><FONT face=arial size=2><B>&#160;&#160;MSIE 5&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;Windows
98&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;17
Jun, Sat, 17:41:29&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;spider-wd013.proxy.aol.com&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 98&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;19
Jun, Mon, 14:57:11&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;cdm-24-198.tca.net&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 98&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;19
Jun, Mon, 22:55:03&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;pxy-hst-12.tandem.com&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows NT&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;20
Jun, Tue, 09:08:42&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;192.239.216.99&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 95&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;21
Jun, Wed, 12:07:57&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial size=2><B>&#160;&#160;159.98.137.118&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;Netscape
4&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Linux 2&#160;&#160;</TD></TR>
<TR><TD bgcolor=white><FONT color=cc0000 face=arial size=2><B>&#160;&#160;24
Jun, Sat, 20:21:23&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT
face=arial
size=2><B>&#160;&#160;ip24.miami29.fl.pub-ip.psi.net&#160;&#160;</TD><TD
bgcolor=ffffdd align=right><FONT face=arial size=2><B>&#160;&#160;MSIE
5&#160;&#160;</TD><TD bgcolor=ffffdd align=right><FONT face=arial
size=2><B>&#160;&#160;Windows 98&#160;&#160;</TD></TR>

</TABLE></TD></TR></TABLE><P>

Steps to Reproduce: 
1) Go to above page
2) Look at table

Reproducibility: 

always.

Build Date & Platform Bug Found: 

IDless build from 20000626 on Linux

Additional Builds and Platforms Tested On: 

NS 4.7, IE 5.01
(Reporter)

Comment 1

18 years ago
OK, that's build 2000062608/Linux... didn't see the build# at first.

Comment 2

18 years ago
Created attachment 10738 [details]
test case

Comment 3

18 years ago
The test case is a much simpler HTML document exhibiting this behavior.  I have
noticed two things:

1. By changing the font size of "Dave's world" in the second table, you can get
   the divider to appear again.

2. By increasing the cellspacing in the second table, the divider appears again.

Btw, the HTML in your page is really bad.  Lots of unclosed <font> and <b> tags
which I originally thought was the problem.
(Reporter)

Comment 4

18 years ago
Yeah, it's not my page though... it belongs to that page hit tracking company so
I can't fix it...

Comment 5

18 years ago
Seems to be a linux only problem, I dont see the problem with win98 2000062720. 
Both original URL and testcase look fine to me.

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

18 years ago
The test case and url look ok on my current WinNT build.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
Still appears on 2000070920 on *Linux*.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

18 years ago
Kevin, it sounds like this may be Linux only.
Assignee: karnaze → kmcclusk
Status: REOPENED → NEW

Comment 9

18 years ago
This looks fine with today's build
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 10

18 years ago
I am still seeing this on 2000071008...perhaps it depends on what fonts you have
on your system.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 11

18 years ago
I think this bug is similar to 44406, if not a dup.

Comment 12

18 years ago
setting to M22 until KM gets back
Target Milestone: --- → M22

Comment 13

18 years ago
*** Bug 44406 has been marked as a duplicate of this bug. ***
Waqar, can you take a look when you get a chance? Linux only bug.
Assignee: kmcclusk → waqar
Status: REOPENED → NEW

Comment 15

18 years ago
I don't think this is a Linux specific issue.  With a different testcase, I can 
see the same behavior under Windows 2000 [2000071920], Linux [2000071920] and 
Solaris [2000071921].  I will attach the testcase to this bug.  While looking at 
the testcase, depending on the size of your browser window, the 1 pixel "border" 
that leaks through from the background table will show up as 0, 1, or 2 pixels.  
Slowly resize your browser one pixel at a time and watch the "borders" grow, 
shrink and even disappear.  This only seems to happen if I set the table widths 
to percentages.

Note: You can see the same bug at http://search.netscape.com - There is a one 
pixel white "border" leaking through in the "Search the Web or Ask a Question" 
table.  Since it happens on a page that is accessible from hitting the 'search' 
button in front of everyones face, I hope it gets fixed before M22...

Comment 16

18 years ago
Created attachment 11632 [details]
testcase
(Assignee)

Comment 17

18 years ago
This works fine, the display is same as 4.7 on linux.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 18

18 years ago
It is most certainly still there.  Just tested on 2000072009 on Linux.  Notice
that whether it happens depends on what fonts you are using.  I am using serif
adobe-times-iso8859-1 at 16 pixels (serif as default), adobe-courier-iso8859-1
at 13 pixels for fixed-width, and 96 dpi.  Notice that by selecting
enlarge/reduce text size, you may be able to make it appear/disappear.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 19

18 years ago
I'm also still seeing it on 2000072009/Linux, both with the default fonts and
the bitstream-charter/16pixel font I use.

Updated

18 years ago
QA Contact: desale → chrisd

Comment 20

18 years ago
I think this bug has the same roots as bug 45055. It manifests itself in both
Linux and Windows and is probably a cross platform thing. It's a rounding issue
in combination with an assumption made about row height, see bug 45055 for more
information. Windows fonts seem to less easily trigger these rounding issues,
therefore I forced the height of those tables.

Marking this a dupe of bug 45055.

*** This bug has been marked as a duplicate of 45055 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 21

18 years ago
Verified dup
Status: RESOLVED → VERIFIED

Comment 22

17 years ago
*** Bug 44796 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.