Firefox crashes when loading a page

RESOLVED DUPLICATE of bug 369971

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 369971
10 years ago
8 years ago

People

(Reporter: Albert Zeyer, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.9 (like Gecko)
Build Identifier: firefox-3.0_rc1-r1 (Gentoo release)

One of the following pages leads to a crash in Firefox:
http://ubuntuforums.org/showthread.php?t=267334
http://ubuntu-tutorials.com/2007/11/17/install-vmware-server-on-ubuntu-710-gutsy-gibbon-updated/
http://www.howtoforge.de/howto/installation-des-vmware-server-auf-debian-40-etch/

(Or perhaps some iframe on these sites.)

Backtrace:
[Thread 0xb313ab90 (LWP 26709) exited]
[Thread 0xb18eab90 (LWP 26712) exited]
[Thread 0xb10e9b90 (LWP 26713) exited]
[Thread 0xb08e8b90 (LWP 26714) exited]
[Switching to Thread 0xb7d576d0 (LWP 26697)]

Breakpoint 1, gdk_x_error (display=0x8070318, error=0xbfd3dc9c) at gdkmain-x11.c:614
614     gdkmain-x11.c: No such file or directory.
        in gdkmain-x11.c
(gdb) bt
#0  gdk_x_error (display=0x8070318, error=0xbfd3dc9c) at gdkmain-x11.c:614
#1  0xb6f4bbd5 in bonobo_x_error_handler (display=0x8070318, error=0xbfd3dc9c) at bonobo-ui-main.c:58
#2  0xb7635c69 in _XError (dpy=0x8070318, rep=0xbfd3dd60) at XlibInt.c:2905
#3  0xb7637676 in _XReply (dpy=0x8070318, rep=0xbfd3dd60, extra=0, discard=1) at XlibInt.c:1831
#4  0xb7631996 in XSync (dpy=0x8070318, discard=0) at Sync.c:48
#5  0xb7631afb in _XSyncFunction (dpy=0x8070318) at Synchro.c:37
#6  0xb761533b in XCreatePixmap (dpy=0x8070318, d=104, width=<value optimized out>, height=<value optimized out>,
    depth=<value optimized out>) at CrPixmap.c:60
#7  0xb78e1ba1 in IA__gdk_pixmap_new (drawable=0x807dc20, width=10000, height=90, depth=24) at gdkpixmap-x11.c:175
#8  0xb6222173 in gfxPlatformGtk::CreateOffscreenSurface (this=0x81c89e0, size=@0x906cc58, imageFormat=gfxASurface::ImageFormatRGB24)
    at gfxPlatformGtk.cpp:168
#9  0xb621d4f8 in gfxPlatform::OptimizeImage (this=0x81c89e0, aSurface=0x906cc48, format=gfxASurface::ImageFormatRGB24)
    at gfxPlatform.cpp:241
#10 0xb4ee9885 in nsThebesImage::Optimize (this=0x974b988, aContext=0x0) at nsThebesImage.cpp:335
#11 0xb4ef1baf in gfxImageFrame::SetMutable (this=0x81f1718, aMutable=0) at gfxImageFrame.cpp:191
#12 0xb50b4641 in imgContainer::DecodingComplete (this=0x974b918) at imgContainer.cpp:306
#13 0xb50bd3ad in end_callback (png_ptr=0x81f14c0, info_ptr=0x81f05a8) at nsPNGDecoder.cpp:853
#14 0xb50c7fb7 in MOZ_PNG_push_have_end (png_ptr=0x8070318, info_ptr=0x81f05a8) at pngpread.c:1725
#15 0xb50c91d1 in MOZ_PNG_push_read_chunk (png_ptr=0x81f14c0, info_ptr=0x81f05a8) at pngpread.c:344
#16 0xb50c97db in MOZ_PNG_proc_some_data (png_ptr=0xbfd3dc9c, info_ptr=0x8070318) at pngpread.c:56
#17 0xb50c9841 in MOZ_PNG_process_data (png_ptr=0x81f14c0, info_ptr=0x81f05a8, buffer=0x8a4afbc "", buffer_size=303) at pngpread.c:36
#18 0xb50bc704 in ReadDataOut (in=0x9a32f78, closure=0x906cc08, fromRawSegment=0x8a4afbc "", toOffset=0, count=303,
    writeCount=0xbfd3e064) at nsPNGDecoder.cpp:335
#19 0xb7d05605 in nsInputStreamTee::WriteSegmentFun (in=0x9a32f78, closure=0x92d70d8, fromSegment=0x8a4afbc "", offset=0, count=303,
    writeCount=0xbfd3e064) at nsInputStreamTee.cpp:102
#20 0xb7d092d5 in nsPipeInputStream::ReadSegments (this=0x9a32f78,
    writer=0xb7d055ce <nsInputStreamTee::WriteSegmentFun(nsIInputStream*, void*, char const*, unsigned int, unsigned int, unsigned int*)>, closure=0x92d70d8, count=303, readCount=0xbfd3e228) at nsPipe3.cpp:799
#21 0xb7d056d4 in nsInputStreamTee::ReadSegments (this=0x92d70d8, writer=0xb50bc674 <ReadDataOut>, closure=0x906cc08, count=303,
    bytesRead=0xbfd3e228) at nsInputStreamTee.cpp:156
#22 0xb50bbfd1 in nsPNGDecoder::WriteFrom (this=0x906cc08, inStr=0x8070318, count=303, _retval=0xbfd3e228) at nsPNGDecoder.cpp:365
#23 0xb50b9ead in imgRequest::OnDataAvailable (this=0x9a32688, aRequest=0x9a323dc, ctxt=0x0, inStr=0x92d70d8, sourceOffset=5440,
    count=303) at imgRequest.cpp:861
#24 0xb50b6b83 in ProxyListener::OnDataAvailable (this=0x8fa21e8, aRequest=0x9a323dc, ctxt=0x0, inStr=0x92d70d8, sourceOffset=5440,
    count=303) at imgLoader.cpp:877
#25 0xb6ac2d4e in nsStreamListenerTee::OnDataAvailable (this=0x96f6a50, request=0x9a323dc, context=0x0, input=0x9a32f78, offset=5440,
    count=303) at nsStreamListenerTee.cpp:97
#26 0xb6b1e668 in nsHttpChannel::OnDataAvailable (this=0x9a323b0, request=0x9712a38, ctxt=0x0, input=0x9a32f78, offset=5440, count=303)
    at nsHttpChannel.cpp:4522
#27 0xb6aa94a8 in nsInputStreamPump::OnStateTransfer (this=0x9712a38) at nsInputStreamPump.cpp:508
#28 0xb6aa9604 in nsInputStreamPump::OnInputStreamReady (this=0x9712a38, stream=0x9a32f78) at nsInputStreamPump.cpp:398
#29 0xb7d0ac85 in nsInputStreamReadyEvent::Run (this=0x84d2d80) at nsStreamUtils.cpp:111
#30 0xb7d22b73 in nsThread::ProcessNextEvent (this=0x809db00, mayWait=1, result=0xbfd3e420) at nsThread.cpp:510
#31 0xb7ce9523 in NS_ProcessNextEvent_P (thread=0x8070318, mayWait=1) at nsThreadUtils.cpp:227
#32 0xb608c776 in nsBaseAppShell::Run (this=0x8154e20) at nsBaseAppShell.cpp:170
#33 0xb60396f3 in nsAppStartup::Run (this=0x81b5cb8) at nsAppStartup.cpp:181
#34 0xb72b1314 in XRE_main (argc=2, argv=0xbfd3f854, aAppData=0x805ea60) at nsAppRunner.cpp:3170
#35 0x08048f4e in ?? ()
#36 0x00000002 in ?? ()
#37 0xbfd3f854 in ?? ()
#38 0x0805ea60 in ?? ()
#39 0x00000002 in ?? ()
#40 0xbfd3ea04 in ?? ()
#41 0x00000400 in ?? ()
#42 0x00000000 in ?? ()


Reproducible: Always

Steps to Reproduce:
1. Start Firefox.
2. Restore last session.
3. Some of the new tabs I opened there leads to the crash.
(Reporter)

Comment 1

10 years ago
Other installed packags:

=dev-libs/nspr-4.7.1
=dev-libs/nss-3.12_rc3
=net-libs/xulrunner-1.9_rc1
(Reporter)

Comment 2

10 years ago
It is the last page:
http://www.howtoforge.de/howto/installation-des-vmware-server-auf-debian-40-etch/

The other two pages are loading fine.
Severity: critical → blocker
(Reporter)

Comment 3

10 years ago
Firefox 3 rc2 together with xulrunner 1.9 rc2 also has the problem.
Severity: blocker → critical
Keywords: crash
(Reporter)

Comment 4

10 years ago
Firefox 3 rc3 still crashes!
not surprising because thete is no change for RC3 on windows or linux, RC3 only contains a fix for a OS X OS bug.

Your crash seems to be a X or gdk error....
No crash on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1pre) Gecko/2008062402 Minefield/3.1a1pre

Can you try again with the latest nightly?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

(Reporter)

Comment 7

10 years ago
Just visited the page again with Firefox 3 - and no crash this time.

So perhaps some adframe on the site was updated which leads before to the crash?

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 369971
You need to log in before you can comment on or make changes to this bug.