If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 3 RC3 doesn't restore tabs and windows from last session if File, Exit isn't selected.

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Goce Mitevski, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; mk; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; mk; rv:1.9) Gecko/2008052906 Firefox/3.0

Firefox 3 RC3 never restores tabs and windows from latest session if an exit is initialized through the close (x) button in Windows Vista SP1. The tabs are restored only if the exit is applied through the File menu and then selecting Exit(Quit).

Reproducible: Always

Steps to Reproduce:
1.Open Firefox RC3.
2.Open several tabs.
3.Close Firefox through the close button on the upper right corner of the window.
4.Open Firefox again.
5.You'll get the homepage displayed instead of the latest session of tabs and windows.


Expected Results:  
Show the tabs or/and windows from the last Firefox session.
In your steps to reproduce you don't mention what your startup options are. By default, Firefox doesn't restore tabs from the previous session. Presumably you have "When Firefox starts:" set to "Show my windows and tabs from last time", is that correct?

Do you have any extensions installed?
If yes, does the session restore work if you disable them?
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

9 years ago
Yes, I have "Show my windows and tabs from last time" selected and some extensions too (Foxmarks, Adblock Plus, Forecastfox l10n, Gmail Notifier, IE View Lite, URL Fixer, Web Developer) but I noticed the bug before I installed them. Disabling those extensions doesn't change a thing.
Thanks for your reply. The session restore works fine for me on Windows XP with RC3. I'll test Vista later today.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008061105 Minefield/3.0pre

Works for me on Vista as well. Please test with a new profile.

Also, can you compare the contents of sessionstore.js in your old profile folder after exiting Firefox through File -> Exit and with the X Close button.

http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 5

9 years ago
Yes, a new profile solves the problem. Actually, the problem disappeared once I deleted the 'default' profile, and created a new profile with a different name.
I suppose this is not a real bug after all.

Thanks for the help :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Comment 6

9 years ago
I Have the same problem. Deleting the default profile is not an acceptable solution, of course. I'd like to keep my profile.
You need to log in before you can comment on or make changes to this bug.