Closed Bug 438789 Opened 12 years ago Closed 10 years ago

Popup window and Dashboard compatibility

Categories

(Core :: Widget: Cocoa, defect, P3)

All
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- beta4-fixed

People

(Reporter: frantisek.erben, Assigned: mstange)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; cs; rv:1.9) Gecko/2008053008 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; cs; rv:1.9) Gecko/2008053008 Firefox/3.0

Bookmark pop-up menu appear while dashboard activated.

Reproducible: Always

Steps to Reproduce:
1.Make folder with several items or RSS canal in bookmark bar (bar under standard toolbar)
2. Click on this bookmark in bookmark bar - expand into menu.
3. Activate Dashboard (F12 in standard configuration or mouse wheel/ball click)
Actual Results:  
Expanded menu still appear in Dashboard.

Expected Results:  
Expanded menu should disapear and after this action Dashboard activate.

Other occurency this bug (funny):
Doo all Steps to reproduce and make several bookmark folders in bookmark bar. Activate Dashboard with expand any bookmark folder or RSS and move mouse to other bookmark folder or RSS - the another bookmark folder or RSS expand.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → 3.0 Branch
I can confirm this, and here are two more STR:

A)

1) Right-click (or control-click) in a browser page to bring up a
   context menu.

2) Press F12 (to activate Dashboard).

   The context menu stays open, though it should close (as it does in
   Safari and Camino).

B)

1) Type a single letter in the location bar ('w' should do).  This
   will normally match many of the pages you've recently browsed, and
   a drop-down dialog (a combobox) will open with all the possible
   matches.

2) Press F12 to activate Dashboard.

   The combobox should either close or (somehow) get deactivated (as
   it does in Safari).  But instead it stays open and active.

I'll bet this problem happens because FF3 (like FF2) uses a non-native
implementation for its context menus and Places menus.

The solution will (presumably) be to figure out what notification gets
sent when Dashboard is activated, and add code to re-act
appropriately.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → joshmoz
Component: Places → Widget: Cocoa
Product: Firefox → Core
QA Contact: places → cocoa
Version: 3.0 Branch → unspecified
Assignee: joshmoz → smichaud
Flags: wanted1.9.0.x?
Priority: -- → P3
Summary: Bookmark list and Dashboard compatibility → Popup window and Dashboard compatibility
Not wanted for 1.9.0.x, but should be wanted for 1.9.1.
Flags: wanted1.9.1?
Flags: wanted1.9.0.x?
Flags: wanted1.9.0.x-
Flags: wanted1.9.1? → wanted1.9.1+
Duplicate of this bug: 465465
Duplicate of this bug: 473560
Duplicate of this bug: 476043
Actually I think bug 404131 is a special case of this bug, and should be duped here.
Duplicate of this bug: 404131
Duplicate of this bug: 419098
Duplicate of this bug: 322032
Duplicate of this bug: 382096
An even more general issue that seems to be linked:

1) Open any page with links or text
2) Open the Dashboard or a Stack in grid-view
3) Hover over the links or text

Expected results: cursor is the normal black pointer
Actual results: cursor changes to carat or hand.

Also relevant - if the page contains elements that change appearance when moused-over (eg the top bar of the Facebook site), this happens when moused-over with the Dashboard or a Stack open as well.

This is on a new Intel MacbookPro running OSX Leopard 10.5.8.
What you're describing is bug 300904.
Oh I apologise, I didn't see it in the search
Attached patch v1Splinter Review
Easy.
Assignee: smichaud → mstange
Status: NEW → ASSIGNED
Attachment #404187 - Flags: review?(joshmoz)
Attachment #404187 - Flags: review?(joshmoz) → review+
Hardware: PowerPC → All
Version: unspecified → Trunk
http://hg.mozilla.org/mozilla-central/rev/f47c8163a2a5
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Attachment #404187 - Flags: approval1.9.2?
Duplicate of this bug: 527097
Comment on attachment 404187 [details] [diff] [review]
v1

a192=beltzner
Attachment #404187 - Flags: approval1.9.2? → approval1.9.2+
Blocks: 345219
You need to log in before you can comment on or make changes to this bug.