Only the first xul textfield in each pref window is filled in.

VERIFIED WORKSFORME

Status

P3
blocker
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: jelwell, Assigned: matt)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][dogfood-])

(Reporter)

Description

19 years ago
I'm using a CVS pull from 6/26/2000 on Linux.
Steps to reproduce:
1) open prefs window (edit preferences...)
2) click on Advanced ... Cache
3) enter in text for "Disk Cache" and "Disk Cache Folder"
4) Hit ok.
5) reopen prefs
6) go back to cache section
*notice that the text you entered in 3 (above) is gone*

This is true on proxy settings, Navigator ... History (expire time) and pretty
much any other pref window I could find that had more then one xul textfield.
(Reporter)

Updated

19 years ago
Keywords: dogfood, nsbeta2, regression
(Reporter)

Updated

19 years ago
Blocks: 15165
(Reporter)

Comment 1

19 years ago
This bug is blocking my nsbeta2+ bugscape bug from being tested.
http://bugscape/show_bug.cgi?id=1135
Severity: critical → blocker
Target Milestone: --- → M17
(Assignee)

Comment 2

19 years ago
I'm getting an assert saying that saying new code was added to prefapi.h. and 
that pref has not been initialized.

Comment 3

19 years ago
please put the assert in here, prefapi.h hasn't changed
for over a month.
(Assignee)

Comment 4

19 years ago
Here is the assert

###!!! ASSERTION: you added a new error code to prefapi.h and didn't update 
_convertRes:'(res>=PREF_DEFAULT_VALUE_NOT_INITIALIZED)&&(res<=PREF_PROFILE_UPGRA
DE)',file d:\mozilla\modules\libpref\src\nsPref.cpp, line 175

It looks like when the pref is changed that the pref is saved 
in the prefs.js file.  It just does not get loaded in the form.
(Assignee)

Comment 5

19 years ago
So i set some breakpoints and see that the pref is definitly
getting saved.  I'm still not sure what the problem is exactly.

Comment 6

19 years ago
Putting on [nsbeta2+][dogfood-] radar.  Does not need a fix ASAP for daily work, 
but we should fix this for beta2. Please renominate if you can not enter any 
data and/or if there is any real data loss.
Whiteboard: [nsbeta2+][dogfood-]

Comment 7

19 years ago
this works for me on linux/WinNT.  My build is 11:30am today,
matt's build is yesterday's.
(Assignee)

Comment 8

19 years ago
This should work now.  Works for mcafee and works for me on windows.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

19 years ago
marking verified, it's working now.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.