[MLK] Crash after selecting the folder to store profile information

RESOLVED FIXED in M18

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: racham, Assigned: Bill Law)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][nsbeta3-])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to reproduce :

* run mozilla -profilemanager
* click on Create Profile button to bring the profile wizard..
* go the page2 of the wizard
* use the default/provide the profile name
* click on Choose Folder button
* Select a folder from the file picker
* Click on OK of that window
* Crash..

Bill Law added code to choose the right deallocator while fixing the bug 
42384 and it is the place where it is crasing now. 

Adding pavlov, grace and myself to the cc list.
(Reporter)

Comment 1

18 years ago
Adding nsbeta2, crash keywords
Keywords: crash, nsbeta2
(Reporter)

Comment 2

18 years ago
*** Bug 42392 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

18 years ago
Created attachment 10678 [details]
stack trace
(Assignee)

Comment 4

18 years ago
Fix checked in ; forgot some parentheses in expression to calculate unicode 
string length.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
I am still crashing with build 000062709 on WinNT and Win95 but not Win98
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 6

18 years ago
With 2000062709, I do not crash on win95, or on win2k (aka nt 5.0).
Any additional steps to get this crash? (I could reproduce easily with
yesterday's build). 

Comment 7

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 8

18 years ago
I don't see this crash either.  Bill, does it happen for you?
Target Milestone: --- → M18
(Assignee)

Comment 9

18 years ago
I think it's fixed.  I'll try closing it again and see if it sticks this time.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
I can verify on builds for 6/29 (WIn95/NT/Mac) - not crashing anymore.
(Linux has another bug- no scroll bar in file picker- but it was working there
before)

Comment 11

18 years ago
verified. does not crash 2000062914 win95 (respin), 2000062914 linux respin), 
2000062914 mac (respin)

FYI: The "no scrollbar" in the tree of the filepicker bug is bug 43467 (which
covers this as general problem with tree scrollbars).
Status: RESOLVED → VERIFIED

Comment 12

18 years ago
aach,

still crashing on build 2000070509- thought I reopened yesterday ?
on Win95, Win98 and WinNT.. sometimes crash on ok button in file picker but more 
often on finish button in Create Profile WIzard
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 13

18 years ago
I am unable to reproduce any failure on either Win98 or WinNT.

Is there something special I have to do?

Seems odd that this would have reappeared after having been fixed for a few
days.  The code hasnt changed at all.

Comment 14

18 years ago
I can't reproduce this with 2000070608 on either win95 or win2k. 

Comment 15

18 years ago
Putting on [nsbeta2-] per Nav Beta2 review today.  Only gbush seeing this.
Whiteboard: [nsbeta2+] → [nsbeta2-]

Comment 16

18 years ago
nav triage team:
nsbeta3-
will be evaluated in memory leak team
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3-]

Comment 17

18 years ago
worksforme 20000724nn win95, win98, win2k
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Adding keyword to bugs with nsbeta3 triage value in status whiteboard so 
tracking queries will not be misled
Keywords: nsbeta3
You need to log in before you can comment on or make changes to this bug.