View source graphical gunk on asciimation.co.nz

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
3 years ago

People

(Reporter: thomas, Unassigned)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0

Viewing the source of asciimation.co.nz produces a load of graphic gunk, seemingly from the graphic buffer (you can sometimes see a scrambled website logo in it). Is it possible that the long string at the beginning is causing this?

Reproducible: Always

Steps to Reproduce:
1. Navigate to asciimation.co.nz
2. View source of page
3. Admire the contents of your graphical buffer. Sometimes it starts off blank but once you scroll gunk starts showing up. 
Actual Results:  
Gunk.

Expected Results:  
No gunk.

Comment 1

11 years ago
Created attachment 325013 [details]
testcase (gzipped)

This is caused by very long lines in the the source (more that 1 million characters). This gzipped testcase contains such a long line. Load it with view-source:... and try to resize the browser window. Garbage will appear on screen.

With a debug build, I'm getting assertions like:
nsLineLayout: Text(293)@0x852990 metrics=1720320,900!
nsLineLayout: Text(294)@0x8529f8 metrics=1720320,900!

(CRAZY_WIDTH macro is returning true)

Updated

11 years ago
Status: UNCONFIRMED → NEW
Component: View Source → Layout
Ever confirmed: true
Keywords: regression, testcase
OS: Linux → All
Product: Firefox → Core
QA Contact: view.source → layout
Hardware: PC → All
Version: unspecified → Trunk
(Reporter)

Comment 2

11 years ago
Appears to be a regression as on Firefox 2.0.0.14 there is no gunk. 

Comment 3

9 years ago
Still an issue with

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.11) Gecko/2009061319 Iceweasel/3.0.11 (Debian-3.0.11-1)

Could someone please mark it as something major? The "gunk" looks bad enough to be an actual memory management issue.

Comment 4

3 years ago
Not reproducible in windows-XP with latest Nightly and release.
Considering this, I will mark this issue as Resolved-WORKSFORME. If anyone can still reproduce it, feel free to reopen the issue and provide more information. Thanks

--
Version 	48.0a1
Build ID 	20160419030312
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:48.0) Gecko/20100101 Firefox/48.0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 5

3 years ago
Version 	48.0a1
Build ID 	20160419030312
Update Channel 	nightly
User Agent 	Mozilla/5.0 (X11; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0
You need to log in before you can comment on or make changes to this bug.