Some Relative link does not work

VERIFIED FIXED

Status

SeaMonkey
Build Config
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Katsuhiko Momoi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When you click on any Japanese link, the link will go to the wrong page.

Steps of reproduce
1. Go to above URL
2. Click on "use Auto detect for Japanese"

It should go to http://babel/tests/browser/charoverride/nonframe/janometa.html,
but it will go to http://babel/ja/index.html and "Not found" error will show up.

3. Click on "JA" under "B. Try Korean, Japanese, Simplified Chinese, Traditional 
Chinese auto-detect module. There should be no change. "
  
It should go to 
http://babel/tests/browser/charoverride/nonframe/overridetest_case.html
but it will go to http://babel/ja/index.html and "Not found" error will show up.

4. Click on "JA" under "B. Try Shift_JIS, EUC-KR, GB2312, and Big5. These menu 
items should restore the correct display. "

It should go to 
http://babel/tests/browser/charoverride/nonframe/jawrongmeta.html
but it will go to http://babel/ja/index.html and "Not found" error will show up.

5. Click on "Japanese (page displayed in Japanese)"
http://babel/tests/browser/charoverride/nonframe/janometa.html
but it will go to http://babel/ja/index.html and "Not found" error will show up.

Other relative links work fine.

Tested 2000-6-26-08 Win32, Mac, and Linux build.
(Assignee)

Comment 1

18 years ago
Sorry about this problem.
When the original test cases were created, we copied
the Netscape Japan Home page. For the Japan page only,
there is a JS user-agent sniffying code because there was
Netscape 6 Beta 1 and they wanted to present a different
page than what you get for Communicator 4.x.
So the JS re-routes access from Netscape or Mozilla version 5 or 
above to: /ja/index.html. This is what you're seeing as an
effect. 
For the current test cases, we don't need such re-routing, so
I eliminated the sniffer code from the problem pages.  
This makes all the Japanese link work OK. 

Marking it resolved fixed. Please verify.
Assignee: cls → momoi
QA Contact: granrose → teruko
(Assignee)

Comment 2

18 years ago
Changing the resolution.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

18 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.