nsHTMLDocument::UpdateIdTableEntry should not return an error just because the ID table is not live

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

Created attachment 324910 [details] [diff] [review]
fix

It does NS_ENSURE_TRUE(entry, NS_ERROR_OUT_OF_MEMORY); when the entry may be null just because the ID table is not live and the ID is not being tracked. In that case we should return NS_OK. I couldn't come up with a testcase where this causes a problem but it is worrying.
Attachment #324910 - Flags: superreview?(jonas)
Attachment #324910 - Flags: review?(jonas)
Duplicate of this bug: 433648
Comment on attachment 324910 [details] [diff] [review]
fix

I think it'll only return null for out-of-memory. If there is no entry it'll return a non-null-but-not-busy entry.
I guess you're right!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Attachment #324910 - Attachment is obsolete: true
Attachment #324910 - Flags: superreview?(jonas)
Attachment #324910 - Flags: review?(jonas)

Updated

10 years ago
Component: DOM: Core → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.