Last Comment Bug 4390 - {feature} Need extensions to transaction manager to support Japanese Input
: {feature} Need extensions to transaction manager to support Japanese Input
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All Windows NT
: P3 major (vote)
: M6
Assigned To: kinmoz
: sujay
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-29 16:34 PST by tague
Modified: 2001-09-12 00:43 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description tague 1999-03-29 16:34:07 PST
To correctly support Japanese input, I want to be able to create a secondary
transaction "stack" which can't interact with the main transaction stack of the
application, to represent the changes that occur while an input method is being
used.  I attempted to use the batching features - but the batching functions do
not support transactions in the style that I need.

Let's say I've typed ABC into the editor, and now I engage the input method by
selecting it from the keyboard menu.  I type kakikukeko and then <return> to
signal that I am done with the input method.  While I am typing with the input
method engaged - I can't completely commit the changes that I am typing into
the main editor buffer until the <return> key is pressed.  The kakikukeko
string needs to be editable independent (and unable to affect) the string ABC.
Once I hit return, the transaction manager needs to create a new transaction
which represents inserting the entire string kakikukeko into the text buffer as
an atomic insert.

Please contact for more details and explaination about what I need.  It's
difficult to describe in a bug report, but I can demonstrate how this needs to
work in person.
Comment 1 Greg Kostello 1999-03-29 16:45:59 PST
Changing this to a feature request and assigning this to Kin. Let's discuss this
in our team meeting.
Comment 2 tague 1999-03-29 16:48:59 PST
Greg :-  This is something I need to complete work scheduled for the M4
milestone.
Comment 3 kinmoz 1999-04-06 09:56:59 PDT
Changed status to assigned and the milestone to M5.
Comment 4 kinmoz 1999-04-28 08:53:59 PDT
Changed milestone to M6.
Comment 5 tague 1999-05-06 14:17:59 PDT
This should have goten fixed with the work we did in M5.  I'm moving it to
verified since it's a code/design issue.

Note You need to log in before you can comment on or make changes to this bug.