If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Main content of some pages are not shown

VERIFIED FIXED

Status

support.mozilla.org
General
--
blocker
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: dynamis (Tomoya ASAI), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Step to reproduce:
1. Confirm that you are logout
2. Go user info page:
   ex. http://support.mozilla.com/tiki-user_information.php?locale=ja&userId=2
3. Nothing will be shown in the main contents block where the user info should be shown
4. Go some translated article page:
   ex. http://support.mozilla.com/ja/kb/%E8%A8%AD%E5%AE%9A%E3%82%A6%E3%82%A3%E3%83%B3%E3%83%89%E3%82%A6
5. You'll see only below in the main contents block:
このページへの貢献者:°: dynamis , a , marsf and° mozilla_help_viewer_project .
最終変更日時° 2008年06月04日 水曜日 20時25分34秒 (PST).
- This is a help article -

A. Login
B. Go user info page again:
   ex. http://support.mozilla.com/tiki-user_information.php?locale=ja&userId=2
C. You'll see the user info correctly
D. Go some translated article page again
   ex. http://support.mozilla.com/ja/kb/%E8%A8%AD%E5%AE%9A%E3%82%A6%E3%82%A3%E3%83%B3%E3%83%89%E3%82%A6
E. You can see page contents correctly

Some translated page are shown without login:
http://support.mozilla.com/ja/kb/%E8%A8%AD%E5%AE%9A%E6%83%85%E5%A0%B1%E3%81%AE%E3%83%90%E3%83%83%E3%82%AF%E3%82%A2%E3%83%83%E3%83%97
http://support.mozilla.com/ja/kb/Firefox+%E3%81%AF%E3%81%99%E3%81%A7%E3%81%AB%E8%B5%B7%E5%8B%95%E3%81%97%E3%81%A6%E3%81%84%E3%81%BE%E3%81%99%E3%81%8C%E5%8F%8D%E5%BF%9C%E3%81%8C%E3%81%82%E3%82%8A%E3%81%BE%E3%81%9B%E3%82%93
http://support.mozilla.com/ja/kb/%E6%A4%9C%E7%B4%A2%E5%80%99%E8%A3%9C%E3%81%AE%E5%88%A9%E7%94%A8

but some pages are not:
http://support.mozilla.com/ja/kb/Web+%E3%82%B5%E3%82%A4%E3%83%88%E3%81%AE%E8%AA%AD%E3%81%BF%E8%BE%BC%E3%81%BF%E3%82%A8%E3%83%A9%E3%83%BC
http://support.mozilla.com/ja/kb/Firefox+%E3%81%AE%E3%82%AD%E3%83%A3%E3%83%83%E3%82%B7%E3%83%A5%E3%83%95%E3%82%A1%E3%82%A4%E3%83%AB%E3%81%8C%E3%82%A6%E3%82%A4%E3%83%AB%E3%82%B9%E3%81%AB%E6%84%9F%E6%9F%93%E3%81%97%E3%81%9F

Even if the page is not translated yet, we should be able to see English page or some error message saying that the article is not translated/approved yet.
(Reporter)

Updated

9 years ago
Severity: major → critical
I experienced this after clicking on [Save], when creating a new page. A reload fixed it.
Summary: Main content of some translated pages are not shown without login. → Main content of some pages are not shown

Comment 2

9 years ago
Let me describe what I see as a possible problem:

For these pages I see when I am NOT logged in, only the page footer area but no
page content:

http://support.mozilla.com/ja/kb/%E8%A8%AD%E5%AE%9A%E6%83%85%E5%A0%B1%E3%81%AE%E3%83%90%E3%83%83%E3%82%AF%E3%82%A2%E3%83%83%E3%83%97
http://support.mozilla.com/ja/kb/Firefox+%E3%81%AF%E3%81%99%E3%81%A7%E3%81%AB%E8%B5%B7%E5%8B%95%E3%81%97%E3%81%A6%E3%81%84%E3%81%BE%E3%81%99%E3%81%8C%E5%8F%8D%E5%BF%9C%E3%81%8C%E3%81%82%E3%82%8A%E3%81%BE%E3%81%9B%E3%82%93
http://support.mozilla.com/ja/kb/%E6%A4%9C%E7%B4%A2%E5%80%99%E8%A3%9C%E3%81%AE%E5%88%A9%E7%94%A8

They can be seen when you are logged in.

Is this the problem?
Created attachment 324960 [details]
screenshot

Correct.
Comment from Firewalls article:
"Hi,
I went to:
http://www.spreadfirefox.com/screencastcontest/articles
and clicked on firewalls.
Firefox was directed to 
http://support.mozilla.com/en-US/kb/Firewalls
BUT - there is no article on firewalls there.. 
Instead, A survey poll on the (non-existent) article was shown.   :-) 
I really like firefox and want to ditch Kaspersky antivirus - it makes firefox hang.
Jay
Maybe an "under construction" message would help."
May or may not be the same problem, but I also get bank pages when trying to access some admin articles.
http://support.mozilla.com/en-US/kb/Updating+in-product+help+for+your+locale

Comment 5

9 years ago
>http://support.mozilla.com/ja/kb/%E8%A8%AD%E5%AE%9A%E6%83%85%E5%A0%B1%E3%81%AE%E3%83%90%E3%83%83%E3%82%AF%E3%82%A2%E3%83%83%E3%83%97
>
this 1st one seems to be fixed for me now


>http://support.mozilla.com/ja/kb/Firefox+%E3%81%AF%E3%81%99%E3%81%A7%E3%81%AB%E8%B5%B7%E5%8B%95%E3%81%97%E3%81%A6%E3%81%84%E3%81%BE%E3%81%99%E3%81%8C%E5%8F%8D%E5%BF%9C%E3%81%8C%E3%81%82%E3%82%8A%E3%81%BE%E3%81%9B%E3%82%93
> >http://support.mozilla.com/ja/kb/%E6%A4%9C%E7%B4%A2%E5%80%99%E8%A3%9C%E3%81%AE%E5%88%A9%E7%94%A8
>

These 2 still have a problem. The interesting thing is that these seem to have
the "interactive translation tag next to some text (the circles), which is
strange.

> They can be seen when you are logged in.
> 
> Is this the problem?
> 

Comment 6

9 years ago
Confirmed on firewall artice

Comment 7

9 years ago
I tried re-saving and approving Firewall article. It seems to have fixed it (with a slight delay for the netscaler cache to refresh it).

Comment 8

9 years ago
seems to be affecting non-article pages as well, like login page and user info page - so I'm not 100% sure of the cause and effect of re-saving and approving.

(In reply to comment #7)
> I tried re-saving and approving Firewall article. It seems to have fixed it
> (with a slight delay for the netscaler cache to refresh it).
> 

-->Blocker
I'm getting more article comments about this. This time on http://support.mozilla.com/en-US/kb/Managing+profiles
Severity: critical → blocker
I think it's a memcache issue.  Looking into it.
Severity: blocker → critical
I seem to have accidentally set this back to critical, fixing.

Nelson and I are both working on this, we believe it's a caching issue and are working on a reproducible test for the cause of the bug.
Severity: critical → blocker

Comment 12

9 years ago
Apparently, pages were just spontaneously not being shown for non-logged in users, even pages that have not been edited for some time. This affected Firefox Help suddenly - so nagios paged justdave. He restarted memcached on both mrapp55 and mrapp56 and the Firefox Help page came back.

The rest of the pages mentioned in this bug seems to be OK now except for:

http://support.mozilla.com/ja/kb/%E6%A4%9C%E7%B4%A2%E5%80%99%E8%A3%9C%E3%81%AE%E5%88%A9%E7%94%A8

Still checking and monitoring.
Created attachment 325028 [details] [diff] [review]
Quick patch to make page cache invalidation happen later

Attaching a quick patch which moves cache invalidation for page approval and rollback as late as possible in the process, in case this is somehow caused by a race condition between one person approving a page and another viewing the page while approval completes.

Still investigating the cause for blank content.
Attachment #325028 - Flags: review?(nelson)
Attachment #325028 - Flags: review?(laura)

Updated

9 years ago
Attachment #325028 - Flags: review?(laura) → review+

Updated

9 years ago
Attachment #325028 - Flags: review?(nelson) → review+

Comment 14

9 years ago
Created attachment 325052 [details] [diff] [review]
patch to avoid caching pages with no content

This patch checks content for main area before allowing it to be cached
Attachment #325052 - Flags: review?(lorchard)
Attachment #325052 - Flags: review?(laura)
Comment on attachment 325052 [details] [diff] [review]
patch to avoid caching pages with no content

You actually want strpos != FALSE.  It can return 0.

Other than that it's good  - fix that, tag, and request another push.
Attachment #325052 - Flags: review?(laura) → review+

Comment 16

9 years ago
You mean strpos === FALSE. Anyway, temporary fix in r15491 in production branch.

(In reply to comment #15)
> (From update of attachment 325052 [details] [diff] [review])
> You actually want strpos != FALSE.  It can return 0.
> 
> Other than that it's good  - fix that, tag, and request another push.
> 

Comment on attachment 325052 [details] [diff] [review]
patch to avoid caching pages with no content

Looks good to me, with the === FALSE tweak.
Attachment #325052 - Flags: review?(lorchard) → review+

Comment 18

9 years ago
You can also reproduce similar problems when logged in as well. But since memcache  is not used for logged in users, refreshing the page usually gets the page back again. Therefore, it is likely that it is a case of memcached caching in an intermittently rendered page with blank areas.

To reproduce, keep refreshing any page when logged in. You will get it intermittently.

Note also the blank parts are consistently the same template area for any theme (for the main home page style - the entire page is blank, but for kb articles, only the article area which corresponds to a particular .tpl file, is blank). There is inconsistency across themes in terms of portions blank, but for each theme it is always the same part. Pages get hit pretty much randomly.

If the templates cache is on the local cluster machine file systems, maybe one of them has a corrupted templates_c cache? Perhaps we should try clearing the cache to test this.


Has anybody been able to repro since justdave flushed the Smarty cache (at 5am EDT Saturday)?  I can't repro the error anymore, so I'm hoping this was our problem.

(If it is indeed the problem we can set it up to page someone/autoflush the cache if the error recurs.)
I haven't seen this since Friday; and I haven't received anymore article comments about it.
No reports since cache clearing.  I'm going to call this done.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED

Updated

8 years ago
Whiteboard: sumo_triage

Updated

8 years ago
Whiteboard: sumo_triage → sumo_only
You need to log in before you can comment on or make changes to this bug.