Closed Bug 439275 Opened 14 years ago Closed 14 years ago

right click from saved bookmark goes direct to link and does not provide "open link in New window/Tab" menu

Categories

(Firefox :: Bookmarks & History, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 300710

People

(Reporter: stockwiz99, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

right click from bookmark does not provide open link in New window/Tab menu yet right click from a hot link works perfect using mighty mouse or trackpad? So it's not a hardware issue.

Reproducible: Always

Steps to Reproduce:
1.just try and right click on any saved book mark
2.
3.
Actual Results:  
jumps to link location

Expected Results:  
New window/Tab" menu
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 300710
So is it fixed or not??? After looking at the supposed DUPLICATE???
After reading through the threads I am not any closer to knowing what the solution is other than seeing a frustrating ping pong match of verbiage!

Come on guys step to the plate and get it fixed! Buying a Dell and / or installing parallels is NOT the answer!

Give it to me in plain English so I don't need to go find another Browser that actually works on the MAC the way it's suppose to!

Thanks
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Although threats to leave us generally don't work, as I said in bug 300710 comment 13, I'd be interested in hearing what browser you are going to switch to. 

Our behavior is how Mac native menus work, they treat all clicks with any mouse button as a left click, and they do not have context menus. You can see that for yourself by trying to right-click a bookmark in a folder on Safari's toolbar, or right-clicking Get Info in the Finder's Action menu (the gear with a dropdown in the toolbar).

That means you'll need to find another browser which, like us, draws non-native menus within the window (You're very unlikely to find anything that draws a non-native menu for the top menubar, so one that has a context menu for the main Bookmarks menu isn't going to happen). I don't know of any other non-native Mac browsers, but it's possible there is one, or that a native one wrote its own menu control to do just this.

However, please don't reopen this bug. It's a duplicate of bug 300710, which is still open because nobody has fixed it or decided that fixing it is either impossible or the wrong thing to do. No amount of yelling or threatening, here or there, will change that fact, or the fact that this is a duplicate of that.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 300710
You need to log in before you can comment on or make changes to this bug.