No error message for wrong Users or Hosts with some accounts

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: chn42gn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Thunderbird 2.0.0.9  or 14

Smtp = smtp.tele2.fr
account xxx@free.fr
no error message if sending to an inexisting user ou inexsting host 
get error message when sending the same wrong message directly from webmail.free.fr

get errors message when sending the same wrong messages via thunderbird from following FAI
laposte.net
gmail.com
orange.fr
hotmail.com
yahoo.fr

What is wrong with free.

Thanks

Reproducible: Always

Steps to Reproduce:
1.send a message to an inexisting user using a free.fr account
2.send to the same user through an other account (yahoo.....
3.check errors messages
4.send a message to an inexisting host using a free.fr account
5..send the same to an existing host(yahoo.....)
6.check error messages
Actual Results:  
1. gives no error message
2. gives error message (unknown user)
4. gives no error message
5. gives error message (unknown host)

Expected Results:  
1. error  message (user unknown)
4. error message (host unknown)
> What is wrong with free.

Supposedly the server doesn't tell us the user doesn't exist. (While the other servers do.) webmail is not very relevant as is use different technology. 

You can verify it by making an smtp protocol log
http://wiki.mozilla.org/MailNews:Logging

You get the error message as bounce in your pop3/imax inbox if you send it to a different domain.
If sending to an existing user/domain works then your SMTP settings are correct and the server should be able to send the bounce to the right person.
The SMTP server can only deny accepting the message in the same domain but this is disabled in many cases because you can easy check if a user in the domain exists and this could give SPAM senders a nice list of existing Accounts in that domain. In that case you also get a bounce message instead an error in the SMTP phase of sending the message.

If the bounce isn't there (check also the Junk mail folder) then this is a clear server problem, please ask the free.fr support for help.


marking invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.