Do you want Firefox to save your tabs for the next time it starts?




Tabbed Browser
10 years ago
10 years ago


(Reporter: Ron, Unassigned)


Firefox Tracking Flags

(Not tracked)




10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

This function does not appear to be functioning properly.  It prompts me every time I close Firefox, but if I choose to "Save and Quit," the next time Firefox is started, I get nothing but a blank browser.  The tabs that were "saved" don't reopen nor do my home pages.  And there's nothing in the history.  I have to hit the home button to open my home pages.  If I choose not to save the open tabs when closing, then the next time I restart, the home pages open just fine.  However, just to clarify, the home pages are not the issue.  The issue is that the save tabs for next restart is not functioning, no matter what sites I am on.

Reproducible: Always

Steps to Reproduce:
1.Open random sites in tabs
2.Close firefox and choose to "save and quit" when prompted
3.Reopen firefox and NO pages open, not even home pages
Actual Results:  
Blank browser window after restarting

Expected Results:  
I expected my tabs that were open when I closed Firefox to reopen
possible dupe of bug 435055
Do you get this always ?
Do you use Tabmix plus ?
Do you get this also if you closed Firefox running in the Firefox safemode ?

Comment 2

10 years ago
Yes, this always happens.

I used tabmix plus with Firefox 2 but it's not compatible with Firefox 3, so I uninstalled it.

In safe mode, I'm not even prompted to save the tabs that are currently open.

This happens on my laptop as well with a clean install of Windows XP and no Firefox plugins.

Comment 3

10 years ago
I've figured out the problem.  I have Firefox configured, under privacy options, to clear my browsing history whenever the browser is closed.  When I unchecked that option, I no longer have the problem.  I don't know if that's the way it should be or if it really is a bug.  But either way, I'm satisfied now.
Last Resolved: 10 years ago
Resolution: --- → FIXED


10 years ago
Resolution: FIXED → INVALID
It's a UI problem, this settings are conflicting.
I think we have a bug about that somewhere but it's currently unknown how to solve this.
You need to log in before you can comment on or make changes to this bug.