do not load color background if has a semicolon

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: Brahndo Agni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.50 (Windows NT 5.1; U; pt-BR)
Build Identifier: Mozilla Firefox 1.5, Mozilla Firefox 2.0.0.14 and Mozilla Firefox 3.0 RC3

Open right in Opera and passes on the W3C Validator


If passes in the Validator should open of the same mode in all browsers, should not?

Reproducible: Always

Actual Results:  
Do not load color background if has a semicolon (;) in the end of the bgcolor attribute


It's the same bug that have been reported:

https://bugzilla.mozilla.org/show_bug.cgi?id=176248
Then do not report it again if it's already been reported
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 176248
(Reporter)

Comment 3

10 years ago
I think that I have committed a mistake

It's not the same bug that have been reported
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

9 years ago
Thanks for reporting.

According to HTML 4.01, a semicolon is not allowed as a color value (the validator is wrong in this case). However, HTML 4.01 does not specify error handling for this case, so the layout created by Safari and Opera is not necessarily wrong. For best interoperability you should prefer the variant without semicolon, though.

This problem will lekiely be fixed by HTML 5. But for now this is no bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.