Closed Bug 439417 Opened 16 years ago Closed 10 months ago

Customized implementation of a couple of Mozilla functions

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement

Tracking

()

RESOLVED INVALID

People

(Reporter: madhu.tadiparthi, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

The method "static nscoord* lo_parse_coord_list(char *str, PRInt32* value_cnt)" in file "source/layout/html/base/src/nsImageMap.cpp" parses a coordinate list. 
The method "nsresult nsListControlFrame::ScrollToFrame(nsIContent* aOptElement)" in file "source/layout/html/forms/src/nsListControlFrame.cpp" scrolls to frame.

We could customize the above methods for our need by reusing some snippets/logic from the above, and coming out with our own customized methods to suit our context (like argument list, class structure). If Mozilla provides a ready-made method spec, class structure etc as we are using, we could try and directly reuse them, rather than use our customized code. (For reference, we have attached 2 files (see Files.zip) where we are using some portions of the above mentioned Mozilla files to create our own customized method implementations.)


Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
Whiteboard: [CLOSEME 2010-11-01]
Severity: normal → S3

No longer relevant

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: