If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

form manager doesn't save points in email addresses at some times

RESOLVED WORKSFORME

Status

()

Toolkit
Form Manager
--
minor
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: souli, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0

On this site and many other sites are email-fields. My address contains a point. abc.test@test.com. Something like this, you know? On the SpreadFirefox form and others the address is saved in the form manager as test@test.com, even if I type abc.test@test.com it won't save it. But on other websites it works... Like this one: https://bugzilla.mozilla.org/createaccount.cgi
But there I can't retrieve all my email addresses, so the form manager set the field tehre as another one.

Reproducible: Always

Steps to Reproduce:
1. Go on http://www.spreadfirefox.com/en-US/worldrecord/pledge and type in an email address with a point in there, maybe test.test@test.com (;
2. send it
3.Go to http://www.spreadfirefox.com/en-US/worldrecord/pledge and double click on the email address form. only test@test.com is saved.
4. Go to https://bugzilla.mozilla.org/createaccount.cgi and do the same as written above - you'll see abc.test@test.com is saved



Maybe it's cause there are only 3 letters before the point?
(Reporter)

Updated

9 years ago
OS: All → Windows XP
Version: unspecified → 3.0 Branch

Comment 1

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Hmm, since the pledge site is down, I can't really test this. This is not a problem on bugzilla.mozilla.org nor is a problem on GMail sign-up. Can you provide a different site where this malfunctions as you say?

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.