open tab in background is ignored when being asked for cookie verification

VERIFIED DUPLICATE of bug 405239

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 405239
10 years ago
10 years ago

People

(Reporter: Chris Williams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

This appears to be a change since Firefox v2

When tabs are set to open in the background AND cookies are set to "ask me every time" the tabbed paged is foregrounded along with the cookie dialog box.

In v2, the cookie dialog would open in the current tab and the new tab would stay backgrounded correctly.

Reproducible: Always

Steps to Reproduce:
1. In Preferences -> Tabs: unselect "When I open a link in a new tab, switch to it immediately.
2. In Preferences -> Privacy: Select "Accept cookies from sites", "Accept third-party cookies", set "keep until:" to "ask me every time"
3. Middle-click on a link that wants to set a cookie.
Actual Results:  
The new page will begin loading in a backgrounded tab.  When the cookie request is reached, the tab is foregrounded along with the confirm cookie dialog box.  After the dialog box is taken care of, the browser stays on the newly foregrounded tab.

Expected Results:  
The new page used to fully load in the background. When the cookie request is reached, the confirm cookie dialog box should pop up in the currently opened tab.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405239
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.