Closed Bug 439486 Opened 12 years ago Closed 12 years ago

Right-clicking on an IMAP or NNTP folder, selecting Subscribe displays empty folder list

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3

People

(Reporter: Chris, Assigned: jminta)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [T.M.=Thunderbird 3.0a2])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008061603 Thunderbird/3.0a2pre ID:2008061603

When right clicking on an IMAP folder and selecting subscribe, the window which normally allows you to select folders to subscribe to or unsubscribe from is blank, looking like this:

+---------------------------------------+
|    Account: ========================= |
| Show items: [_______________________] |
|  _____________                        |
| |_|New Groups|_______________________ |
| |                                   | |
| | +-------------------+  Subscribe  | |
| | |                   | Unsubscribe | |
| | |                   |   Refresh   | |
| | |                   |     Stop    | |
| | |                   |             | |
| | +-------------------+             | |
| |___________________________________| |
|                                       |
+---------------------------------------+

However, right-clicking the account name and selecting Subscribe correctly populates the window with the folders.

Possibly related to Bug 428662?

Reproducible: Always

Steps to Reproduce:
1. Right-click IMAP folder
2. Select Subscribe
Actual Results:  
An empty window is displayed where folders should be

Expected Results:  
See IMAP folders with option to subscribe or unsubscribe.

I am setup with secure IMAP.  I have not tested this with an insecure server.
Confirming (Checked with Tb trunk on MS Win-XP SP2)
> Worksforme : Name=Thunderbird,Version=3.0a2pre,BuildID=2008060203
> Confirmed  : Name=Thunderbird,Version=3.0a2pre,BuildID=2008061203
> Confirmed  : Name=Thunderbird,Version=3.0a2pre,BuildID=2008061603
Status: UNCONFIRMED → NEW
Ever confirmed: true
I checked with Gmail IMAP account.
works version 3.0a2pre (2008060508)
works version 3.0a2pre (2008060603)
works version 3.0a2pre (2008060703)
fails version 3.0a2pre (2008060808)
A range which neatly encapsulates bug 436630 part 1, and pretty much nothing else.
Flags: blocking-thunderbird3.0a2+
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
Summary: Right-clicking on an IMAP folder, selecting Subscribe displays empty folder list → Right-clicking on an IMAP or NNTP folder, selecting Subscribe displays empty folder list
Version: unspecified → Trunk
Blocks: 436630
The error console includes the message "can't find folder to select."  It'd be really helpful for people to check that when filing rdf-regression bugs.  That error happens because we try to select the child folder, but the menu only handles accounts.  This patch forces us to select root-folders only.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #325650 - Flags: review?(dmose)
Comment on attachment 325650 [details] [diff] [review]
patch
[Checkin: Comment 7]

Since this is a regression, r=dmose for this patch, conditional on:

a) since the selection code in SetUpServerMenu no longer works, just get rid of that function entirely and call SetServerTypeSpecificTextValues directly instead.  The fact that we're no longer explicitly selecting anything in the case where a caller doesn't pass in preselectedURI is probably ok, though it's possible that someone else watching this bug knows differently.

b) file a bug to sort out what the UX here should be.  The idea that an item in the context menu for a folder should be operating on something other than the folder itself strikes me as bizarre and probably wrong.

c) file a bug on cleaning up SubscribeOnLoad to actually be readable & maintainable
Attachment #325650 - Flags: review?(dmose) → review+
Patch checked in, leaving bug open to handle follow-up stuff tomorrow.
Checking in mail/base/content/subscribe.js;
/cvsroot/mozilla/mail/base/content/subscribe.js,v  <--  subscribe.js
new revision: 1.16; previous revision: 1.15
done
Whiteboard: [checked in; needs followup bugfiling]
As the original reporter, this is working for me now with 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1pre) Gecko/2008062403 Thunderbird/3.0a2pre ID:2008062403
Bug 441704 and Bug Bug 441705 have been filed as dmose requested.  Closing this bug.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checked in; needs followup bugfiling]
Target Milestone: --- → Thunderbird 3
Attachment #325650 - Attachment description: patch → patch [Checkin: Comment 7]
(In reply to comment #4)
> A range which neatly encapsulates bug 436630 part 1

Ftr, the line fixed by the patch here is from bug 413781 (which landed much earlier than this regression):
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/mail/base/content/subscribe.js&rev=HEAD&mark=1.16,1.14#1.17
SeaMonkey will port the latter in bug 444913.
Blocks: 444913
Depends on: 413781
Whiteboard: [T.M.=Thunderbird 3.0a2]
You need to log in before you can comment on or make changes to this bug.