Single Loop Animated Gifs all loop again on Ajax http request.

RESOLVED DUPLICATE of bug 284511

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 284511
10 years ago
10 years ago

People

(Reporter: James, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

I'm only referring to single loop animated gifs which are set this way when the gif is created. My images are about 8KB and have approximately 15 frames. The size of these images are 64x28px.

My intended use; I use Ajax to retrieve information from php functions and display this information inside div areas with the updates usually coming through from JavaScript innerHTML function. The Animated Gif sits next to the button requesting the particular function and updates on Ajax status codes. I currently have 3 buttons that perform 3 different kind of updates. Each status image (Animated Gif) has a unique id (although this isn't important see below under "my findings" for why). When Ajax requests some information (regardless of which of the 3 functions) ALL of my Animated Gif status images update and loop back through. They synchronise with the one changing when it runs through the final image. Example;

Ani-Gif 'A' Switches through 2 different images: one to show loading and the other to show complete.

Ani-Gif 'B' is the same

Ani-Gif 'C' is the same

Because all requests on the page are complete all 3 images run through the complete notice animation. If I pressed to process the request for the button which controls Ani-Gif 'A' the image will change to loading. The other 2 images 'B' and 'C' will still stay as they are. Its only when Ani-Gif changes to the complete gif (the same gif that B & C are using) that all 3 reset and run in sequence with one-another.

My Findings;
I have tried renaming the Animated Gifs on my page but this hasn't worked. I found after trying to solve the problem that if any animated gifs are present on the page then they will ALL have the same behaviour regardless if they are connected to Ajax HTTP Request status and if they have a name/id present or not.

Ajax seems to be the trigger but I imagine that the Gif image handler is the cause.

Reproducible: Always

Steps to Reproduce:
1.Insert a animated gif image onto a page with Ajax. (The Ani-gif should be set by the creation software to loop only once).
2.Press to request an Ajax HTTP Request.
3.The image will reset. 


Actual Results:  
Please see above under "Details"

Expected Results:  
Animated gifs intended to show only once need only show once as intended! 

My ani-gifs show the status of my Ajax requests and the way that this works at the moment everytime I click one request it would look to the user that all 3 have been requested.

I have tested this on the following;

Firefox 2 (latest update)  -Fail (Id get the version number but I cant get to it without closing this one down)
Firefox 3 (which Im using now) -Fail
Flock Browser 1.2.1 - Fail
Safari browser 3.1.1 (525.17) - Fail
Opera Browser 9.50 (build 10063) - Pass
Avant Browser 11.6 (Buidl 19) - Pass (although there seems to be a bug with the running of the animation, however the bug I am refering to is not present on this browser)
M$ Internet Explorer Ver(Attempt number) 7.0.5730.13 - Pass (although there seems to be a bug with the running of the animation, however the bug I am refering to is not present on this browser)

I know Flock and FF have the same engine aswel as Avant and M$IE but I thought Id include them in this report anyhow.
(Reporter)

Comment 1

10 years ago
Addition: Ajax is not the only thing that triggers this problem; It seems that any function call has the same affect. 
Can you perhaps post a testcase? (via the add an attachment link above) or at least a URL
(Reporter)

Comment 3

10 years ago
Hi Natch, Ive included a url as a testcase. I was wrong with my additional comment about ajax not being the only thing that triggers the error. I didnt realise that I called an ajax request but found that all my functions do. Anyhow. Since you cant see the PHP script for this test case, Ive included the code for dummyscript.php in my page and for additonal convience Ive also included the code from the Javascript includes.

Heres the url again: http://www.bizybiz.co.uk/testcase/bugzillatestcase.html

Thanks
Hmmm... definitely a bug although I'd suggest looking at bug #284511, this might be a dupe, especially since there the bug is more generic to changing the src of any two gifs with the same initial gif loaded (see the testcase).

This might be somewhat different, your call.

If it's not a dupe, mark it as blocking bug #119597.
(Reporter)

Comment 5

10 years ago
Thanks Natch. It seems the bug is indeed a duplicate of 284511. However I seem to have found the more complicated method of the trigger =). I will now mark this as duplicate. Im new to the whole concept of bugzilla. Im not sure if your on the Mozilla team or if your 3rd party support. Regardless, thanks for taken the time to read my report. What happends now? I realise these things take time to correct but is there any way to check on possible time scales or if and when the problem is fixed will I be informed by emailed?

Thanks again Natch. =D
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 284511
(In reply to comment #5) 
> this as duplicate. Im new to the whole concept of bugzilla. Im not sure if your
> on the Mozilla team or if your 3rd party support. Regardless, thanks for taken

Mozilla is open-source, I am not affiliated with them professionally, but I just try to help when I can ;).

> the time to read my report. What happends now? I realise these things take time
> to correct but is there any way to check on possible time scales or if and when
> the problem is fixed will I be informed by emailed?

Well, if a developer puts up a working patch it'll get fixed! You'll be informed of any updates to this bug, since you're on the cc list of bug 284511, if you don't want that feel free to remove it from the cc list.

Cheers
(Reporter)

Comment 7

10 years ago
Sorry, my history and experience is embedded in the world of M$ where everything has a price and every price is high! My concepts of 'free' and 'developed' software never crossed my mind and over-all a product that 'WORKS'! Im struggling to grasp these concepts =P 

Firefox user since ver 2 - Ill never open IE again - except for testing :/

Thanks for the advice.
You need to log in before you can comment on or make changes to this bug.