Fix links on Press Releases page

RESOLVED FIXED in 1.0

Status

www.mozilla.org
General
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: Samuel Sidler (old account; do not CC), Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

The first paragraph of the Press Releases page has three bad links.

1) "See the weekly" goes to press/kit.html
2) "status update" goes to http://www.mozilla.org/status/ which hasn't been updated since 2004. It should go to http://wiki.mozilla.org/WeeklyUpdates
3) "RSS Feeds" goes to m.o/my-mozilla.html which is highly out of date. I would link to blog.mozilla.com's feed or something similar. (Another page for me to remove on mozilla.org...)

Comment 1

10 years ago
Thanks Sam. We should definitely fix issues #1 and 2. 

I'm not sure if the fix suggested in #3 is the correct one...a better solution, I think would be to create a new RSS feed of our press releases. Am copying Melissa on this, as it's really her call.

This is another one of those "nice to have" fixes...not a pre-launch priority.
Target Milestone: --- → 3.0
(Reporter)

Comment 2

10 years ago
Ah ha! #1 is bug 439542. We aren't closing the sidebar link for "Press kit" properly.
RSS feed should be for Moz press releases.  The blog RSS is already set up and can be scooped up on the blog.moz page.  

Updated

10 years ago
Duplicate of this bug: 443780
#1 and #2 are fixed.  What do you want to happen with #3?
Hey Will - posted the following awhile back - does this help?

RSS feed should be for Moz press releases.  The blog RSS is already set up and
can be scooped up on the blog.moz page.
Yep, thanks.  This is dependent on creating an RSS feed of the news articles then.  I thought there was a bug for that but I don't see it.
(In reply to comment #5)
> #1 and #2 are fixed.  What do you want to happen with #3?

#2 was still broken afaict. I just landed a fix to trunk.

Wil, did a bug ever get on file for creating an RSS feed of news articles? my-mozilla.html doesn't exist on mozilla.org anymore...
> Wil, did a bug ever get on file for creating an RSS feed of news articles?
> my-mozilla.html doesn't exist on mozilla.org anymore...

I don't think so.
(In reply to comment #9)
> I don't think so.

bug 493965.
Cleaning up some old bugs. This page is just around as an archive now - it is no longer updated. I would suggest we replace this line:

"See the weekly status update for the latest updates from the front. To keep track of all the latest Mozilla headlines check out our RSS Feeds."

with:

"See _The Mozilla Blog_ for the latest updates."

John?

Comment 12

7 years ago
(In reply to comment #11)
> Cleaning up some old bugs. This page is just around as an archive now - it is
> no longer updated. I would suggest we replace this line:
> 
> "See the weekly status update for the latest updates from the front. To keep
> track of all the latest Mozilla headlines check out our RSS Feeds."
> 
> with:
> 
> "See _The Mozilla Blog_ for the latest updates."
> 
> John?

Sounds like a good plan to me. Thanks for the cleanup!
Done in trunk in r80282. Merged to stage in r80283.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED
qa-verified-trunk https://www-trunk.stage.mozilla.com/en-US/press/news.html
Keywords: qawanted
Keywords: push-needed
Target Milestone: 3.0 → 1.0
Pushed to production

r80672 | jlong@mozilla.com | 2011-01-12 17:16:20 -0500 (Wed, 12 Jan 2011) | 5 lines
Keywords: push-needed
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.