If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When firefox is in offline mode at startup, weave asks the user for the password

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: UI
--
minor
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Fallen, Unassigned)

Tracking

unspecified
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Experiencing with weave 0.1.30


STR:
* unplug network cable/disconnect network
* start minefield (minefield automatically goes into offline mode)


Results:
* Weave asks the user for his password, the fields are prefilled.


Expected:
* Weave should recognize offline mode and display "Offline" as the status
* When the connection is back, weave should log in

Updated

9 years ago
Target Milestone: -- → 0.3

Comment 1

9 years ago
Very similar use case that I dont think is worth filing a seperate bug for:

On launch of firefox in certain locations I have to switch my proxy. 

Weave will always promt for login credentails even if services.mozilla.com is unreachable. 
If Weave cannot reach services.mozilla.com it should fail silently and not prompt for login creadentials.

Maybe just change the Staus bar inidcator to show the website is unreachable.

Comment 2

9 years ago
These bugs need to be triaged, removing 0.3 milestone setting.
Target Milestone: 0.3 → Future

Comment 3

9 years ago
We should be able to just check Svc.IO.offline and perhaps yield the current function, e.g., yield or login, and have it continue when we get "network:offline-status-changed" topic with data "online".

Not sure if we should show "Offline" in the status bar. Or if we do, make sure we disable the Sign In option.

This would be useful for handling private browsing too.

Updated

9 years ago
Duplicate of this bug: 481158

Updated

9 years ago
Blocks: 481345

Comment 5

9 years ago
http://mxr.mozilla.org/mozilla-central/source/netwerk/base/public/nsIIOService.idl#166

for the offline/online topic and data values.

http://mxr.mozilla.org/mozilla-central/source/netwerk/base/public/nsIPrivateBrowsingService.idl#87

for private browsing enter/exit notifications.

Updated

9 years ago
Depends on: 482007

Updated

9 years ago
No longer blocks: 481345

Updated

9 years ago
No longer depends on: 482007

Updated

8 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general

Updated

8 years ago
Severity: normal → minor
Component: General → Firefox UI
QA Contact: general → firefox
This is WFM now, suspect this was fixed by making the autoconnect call cycle until we can actually log in.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.