javascript error occurs when setting focus at the beginning of mail body (globalOverlay.js)

VERIFIED WORKSFORME

Status

MailNews Core
Composition
P3
major
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: ji, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
On the plain text mail composer, at the beginnning of the mail body, setting
focus at the beginning of the mail body will get JavaScript error. It doesn't
affect the use of the composer, but it's annoyying to see the error everytime
when 
you do the action.

Steps of reproduce:
1. Launch Mail.
2. Bring up plain text mail composer
3. Click mouse to set focus at the beginning of the mail body, you'll see a
JavaScript error
on the console:
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIController.isCommandEnabled]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 42"  data:
no]
(Assignee)

Comment 1

18 years ago
Accepting
Status: NEW → ASSIGNED
Summary: JavaScript wrror occurs when setting focus at the beginning of mail body → JavaScript error occurs when setting focus at the beginning of mail body
Target Milestone: --- → M18

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 2

18 years ago
Moving to future milestone, since it doesn't appear there is any bad end user 
behavior here.
Target Milestone: M18 → Future

Updated

17 years ago
Summary: JavaScript error occurs when setting focus at the beginning of mail body → javascript error occurs when setting focus at the beginning of mail body (globalOverlay.js)

Comment 3

17 years ago
using build 20010501 I no longer see this error.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
I don't see it either. Using may01 commercial trunk build, linux rh 6.2
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.