invalid maxVersion: compatibility range not shown, extension not found by search

VERIFIED DUPLICATE of bug 439500

Status

--
critical
VERIFIED DUPLICATE of bug 439500
11 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Details

(URL)

For All-in-One Sidebar, the compatibility range is not shown. Maybe because the file contains 3.0.0.* as maxVersion?
Yes, I believe this to be the cause of the problem: 3.0.0.* is invalid.

See: http://developer.mozilla.org/devnews/index.php/2007/12/11/ensuring-compatibility-of-add-ons-and-themes-for-firefox-3/

CCing fligtar who knows if the dev CP should have rejected this file from the beginning? If yes, this needs a code fix; otherwise we can probably just fix the ranges for this Add-on.

However, there are already other nominations showing up that have invalid ranges, it seems.
It seems as these add-ons aren't found anymore by the search. Try to find "Pterodactl": No results.
But is here: https://addons.mozilla.org/firefox/addon/3412
Severity: normal → critical
Summary: compatibility range not shown → invalid maxVersion: compatibility range not shown, extension not found by search
Possibly a regression from the update :(
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439500
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.