Closed Bug 439603 Opened 12 years ago Closed 12 years ago

Gcc invoke strange cross initialization error when cross compiling

Categories

(Firefox Build System :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Techrazy.Yang, Assigned: Techrazy.Yang)

References

Details

Attachments

(1 file)

When I cross compile Moizlla for Mingw32 on Linux system with Gcc 4.3.0, I get an strange "cross initialization error" when compile the widget/src/windows/nsNativeThemeWin.cpp. 
And this patch repair that error, indeed it is just a pair of brace.
Attachment #325383 - Flags: review?(roc)
Keywords: checkin-needed
Assignee: nobody → Techrazy.Yang
Pushed to mozilla-central.
Status: NEW → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Duplicate of this bug: 435604
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.