Cannot see all newsgroups offered by NNTP server

VERIFIED WORKSFORME

Status

MailNews Core
Networking: NNTP
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Christian J. Callsen, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
I'm trying to configure news.concentric.net as my news server.
I've got a 4.72 config against that server, and can see the following
newsgroups:

gnu.announce:
gnu.emacs.announce:
gnu.bash.bug:
comp.sys.next.announce:
comp.sys.next.bugs:
comp.sys.next.software:
comp.sys.next:
comp.sys.sun.announce:
comp.sys.sun.apps:
comp.sys.sun:
rec.arts.sf.starwars.games:
rec.arts.startrek.info:
rec.arts.startrek.reviews:
comp.sys.palmtops.pilot:
news.answers:

Mozilla can only see about 4 of the newsgroups of you just connect to the
server and manually subscribe (I had to copy the .rc file to get the rest).

That's probably why it's not able to get any articles from the other groups.
can you expand the tree to see the other groups?

adding karen to the cc list.

(Reporter)

Comment 2

18 years ago
No, expanding the tree doesn't help at all. It's as if the server
doesn't have the newsgroups at all. Neither typing the name or
expanding the tree helps.
type down is broken right now.  (see bug #38905)

what happens when you hit the fresh button?
er, refresh button.
(Reporter)

Comment 5

18 years ago
I first deleted the news server and removed the directory.
Then I recreated the news server. It appears just fine. Then I rightclick
and select subscribe. The "barber pole" rotates. Nothing displays.
If I hit the refresh button the "barber pole" rotates, but nothing
displays in the newsgroup list (a known bug, probably). If I then click
OK, window disappears, and rightclick again, after a few more rotating seconds,
I actually get a list of newsgroup hierarchies.
Under "comp.sys" I see (** = has subgroups):
c.s.ibm
c.s.mac **
c.s.macintosh
c.s.palmtops **
c.s.amiga **
c.s.vms
c.s.newton
c.s.hp
c.s.sun
c.s.sgi
c.s.pens

(interesting selection, btw).

The "gnu" toplevel has only three subgroups (g.gnats, g.cvs and g.misc).

I now hit refresh - ok, I get the rotating barberpole. But it doesn't
stop at all. Wait 10 minutes, because someone interrupts.
Click OK. Rightclick "subscribe". Wait a few secs. Aha! I get more newsgroups
this time. But I'm still missing all of the comp.sys.next hierarchy,
comp.sys.sun hierarchy, lots and lots of newsgroups aren't there.
The "gnu" newsgroups still haven't changed.


Comment 6

18 years ago
Wierd! By testing 06-27-09-M17 commercial build on news.mozilla.org news server:
I am not able to reproduce this scenario, I know that the newsgroups list did 
not display all the newsgroups completely (for news.mozilla.org, still have some 
newsgroups didn't display, but it displayed mostly already). Don't know why from 
your list, it seemed that there were many newsgroups didn't display.....maybe 
this is different news server issue...may I know what kind of the news server 
you have? Can we access that news server/newsgroups? I need to investigate 
more......

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

18 years ago
"news.concentric.net" should be generally available. Give it a shot.

Comment 8

18 years ago
Retesting on "news.concentric.net" for Communicator 4.7 & Netscape 6.0:

I got an Alert: NEWS ERROR: An authorization error occurred.
Please try entering your name and/or password again. No permission.
(Reporter)

Comment 9

18 years ago
Bummer! I guess they only allow people for whom they're an ISP.
Anything I can do to help?

Comment 10

18 years ago
Yes. Can you setup the following to get the NNTP protocol log and attach in this 
bug?
-------------------------------------------------------------------
WinNT: 
Create "c:\tmp" for NNTP log file reside if there is no such directory 
Use the control panel | System | Environment tool to set the
PRLOG env variable: 
Varibles: NSPR_LOG_MODULES  Value: NNTP:5 
Varibles: NSPR_LOG_FILE  Value: c:\tmp\[filename] 
(filename can be defined by you) 
Reboot your system
-----------------------------------------------------------------------

After you attach the NNTP log, it should display the news server information at 
the first few lines, it will look like as following:

0[7b1e80]: 
InitializeNewsFolderFromUri(news://news.mozilla.org:119/netscape.test)
0[7b1e80]: Next state: NNTP_RESPONSE
0[7b1e80]: Receiving: 200 secnews.netscape.com Netscape-Collabra/3.52 03615 NNRP 
ready (posting ok).
0[7b1e80]: received 78 bytes
0[7b1e80]: Next state: SEND_FIRST_NNTP_COMMAND
0[7b1e80]: Sending: GROUP netscape.test

* It will be better to follow the exactly steps to reproduce this problem 
again and attach that whole NNTP log here. Thanks.
(Reporter)

Comment 11

18 years ago
Ok, I set up the environment and rebooted. I then started Mozilla, 
and rightclicked "subscribe" on news.concentric.net (nntp server).
After some seconds I get a newsgroup listing (old values, I'm sure).
The c:\tmp\nntp.log file is empty, so far.
Then I click "refresh" on the Subscribe window. The barberpole starts
rotating. After a few minutes, the nntp.log file is about 893K. It does
not seem to grow. I left it for a few more minutes, and then I clicked OK.
I then rightclick "subscribe" again and get the listing. The displayed
newsgroups didn't seem to change. However, my log listing isn't as detailed
as yours - I've only got some of the information. I'll attach the
log file in the next update.
(Reporter)

Comment 12

18 years ago
Created attachment 10774 [details]
NNTP:5 log of "subscribe" newsgroups from news.concentric.net
(Reporter)

Comment 13

18 years ago
By the way: I couldn't upload the log from Mozilla, so I went to my
ol' trusty Solaris box running moz 4.7 to do it instead.
The upload just timed out.

Comment 14

18 years ago
Yes. Maybe the log is too big. You may send the email to me (huang@netscape.com)
(Reporter)

Comment 15

18 years ago
Are yoy saying that you can't download the attachment? Ok, I'll Email it.

Comment 16

18 years ago
No, you can. But there is limitation for attaching file here, if too big will be 
better to email me.

I still cannot reproduce this problem by uisng today's build for our internal 
news server (Netscape-Collabra/3.52 news server)

From your log, I still have no idea which news server are you using?
Can you provide the news server info to us if you can?

Comment 17

18 years ago
I mean that you can attach file here but except file too big.
I actually got your email for the NNTP log, but it seems it's no useful....
(Reporter)

Comment 18

18 years ago
My point exactly. Would you like me to change the logging settings to get more
detail (I'd need guidance about that).
(Reporter)

Comment 19

18 years ago
On a side note: still reproducible in 2000070420 Win32.

Comment 20

18 years ago
Varibles: NSPR_LOG_MODULES  Value: NNTP:5 
Varibles: NSPR_LOG_FILE  Value: c:\tmp\[filename] 

Above setup is normally we setup for the NNTP log. I really have no idea why 
cannot see the news server info from your NNTP log file....
(Reporter)

Comment 21

18 years ago
Presuming that the '5' refers to a logging level, is there a more detailed level
I could use? I'm using the nightly milestone builds, btw (just in case it makes
a difference).

How would I get the news server info?

Comment 22

18 years ago
The 5 in the first variable above specifies all. the level of logging you want - 
the lower the number the less logging happens. 
We don't control of what greeting the news server should return(That's depends 
on the server implementation)
Can you try the same news servers as me, e.g., news.mozilla.org
I am wondering whether you will get the same log as me or not for accessing the 
same news server....
(Reporter)

Comment 23

18 years ago
I've opened a "telnet news.concentric.net nntp" session (and also one against
news.mozilla.org) and logged the output of the two commands "list" and "quit".

I've tried a few times to create an attachment, so I'm now going to
Email the two logfiles directly to you.
(Reporter)

Comment 24

18 years ago
Files sent. Please let me know if you didn't receive them.

Comment 25

18 years ago
Yes. Thanks -- I got your email.
It seems it shouldn't have problem for listing the newsgroups from your news 
server --the output you get is from the news server itself....I am wondering to 
know why our client cannot handle your news server...I really need to know what 
kind of the news server are you using....
Can you try this bug's same scenario and generating the NNTP log by using the 
news.mozilla.org news server, I am wondering to know whether you will get the 
same NNTP log as me by using the same news server.....

Comment 26

18 years ago
we need to investigate this further before making a decision on whether or not
to nominate this for beta3.

cc'ing bienvenu for any help he can give.
Target Milestone: --- → M18
(Reporter)

Comment 27

18 years ago
Created attachment 11115 [details]
NNTP log of "subscribe" from news.mozilla.org

Updated

18 years ago
QA Contact: lchiang → huang

Comment 28

18 years ago
Thanks.
0[811850]: Receiving: 200 secnews.netscape.com Netscape-Collabra/3.52 03615 NNRP 
ready (posting ok).
It seems that the news server info can be displayed on this log, but why cannot 
display from your news server? David, any idea?

Comment 29

18 years ago
beats me, some problem with the subscribe ui, probably.
(Reporter)

Comment 30

18 years ago
$ ping 43962
43962 is (still) alive.
Mass moving all NEWS bugs from esther to myself.
QA Contact: huang → stephend
Karen - is it alright if I leave you on this bug? I assigned it to myself in a
mass move and it looks pretty complex and you'd have a better handle on it.  

Comment 33

17 years ago
Fine to me.
Changing QA back to Karen, thanks!
QA Contact: stephend → huang
i should be owning QA for this...
QA Contact: huang → stephend
Have you tried this bug lately?  Seth has done lots of work lately on the 
Subscribe dialog. 
clearing milestone, m17 and m18 are meaningless now.  these need to be triages
along with the rest.
Target Milestone: M18 → ---
Christian, please try this again with a new build.  We've fixed several news
caching and connection bugs, so there's a chance everything will be alright for
you!  Please let us know what you find, thanks!
(Reporter)

Comment 39

17 years ago
*applause* (the crowd is cheering)
It seems to be working, Ladies and Gentlemen. The subscriptions are pouring in,
and seems to be a complete list.
I'll reconfigure the Tricorder, eh, Mozilla with a fresh profile and retry
subscribing and reading the newsgroups.
Charming.
Glad to hear it, this bug mystified me ;-)  I'll leave this open until you're 
confident of it working (worksforme).
(Reporter)

Comment 41

17 years ago
I'm going to consider this one fixed. It seems to be working juuuust fine.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 42

17 years ago
(I should mention that this is build 2001010901, 0.7 release version.
If you break it again, at least you'll know when it was working ;)
Thanks, marking verified per Christian's comments.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.