Weave and Password Problem

RESOLVED INVALID

Status

Cloud Services
General
--
critical
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: Andy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Weave 1.3.0

I installed Weave on a Mac (Leopard) and PC (XPSP3) Both initially Sync'ed up well. The next time I loaded Weave on my PC I was notified with 2 Password input prompts consecutively. Then Firefox started up. This then began happening later when I started firefox on my Mac (2 consectuive password prompts). I was worried there was a conflict with Weave's own password feature, so I Unchecked Use Master Password on my Firefox Prefs In each version Mac and PC. I THINK after that the double Prompt dissappeared so a few minutes later I reenabled Passwords on both computers (So they would be secure again). Thats when the Mac Version pretty much stopped working. I loaded firefox and it gave me a unending stream of password prompts to which I enteed my password several times. With about 6 or more failed attempts I pressed escape and skipped the password input. I was then greeted by a weave login password prompt which asked for my weave pass and encryption pass (Looked like a preferences menu item) which also did not want to Login. So now I had a Mac Firefox which I could not login with my master password. I found a link that disabled my master password and reset my Master pass. After that I loaded Firefox 3 with my mac and it seemed like ever second that passed Firefox got slower and slower untill it slowed to a min long crawl for any action that I was doing. EX. if I click any menubar item like tools it took a min to show that menu, or if I scrolled down a web page it took over a min to show the new position of the scrolled page. I'm assuming that weave was trying to sync up during this time. I use a Macbook (White not Pro) and during this time My fan was kicking into overtime. I opened my activity monitor and Firfox was hogging resources. I saw one reading forget which bouncing around 99 on firefox and the other programs on were around 1-15. I have since disabled weave on my mac. Weave is currently running on my PC which I am using now. Weave on PC is seemingly working well tho it does not sync as soon as I click/ask it to.

Reproducible: Didn't try

Steps to Reproduce:
1.Load Weave on Mac and PC have them sync'ed on one account
2.Delete Master Passwords on Both, within Firefox Prefs
3.Login to Each and see if they work
Actual Results:  
One of the two platforms (Mac or PC) may have a problem syncing up. At which point One will not have a current sync and password may be lost.

Expected Results:  
If the Weave Password governs over the FF Master password they should be merged for simplicity.

Give a Prompt Before Disabling Master Passwords when Weave is installed as to the most appropriate way of managing a master password alongside Weave.

Weave needs a Sync Status Bar somewhere noticeable for Weave Users to know if they are interrupting weave during a sync process. So as to keep sync data from corrupting or being interrupted

Comment 1

10 years ago
It is a bit hard to follow your description of the bug, but it sounds like some combination of these:

bug 435094
bug 435100
bug 435880
bug 438396
bug 442981

And possibly others.  This bug is too broad, closing as invalid.  If there are specific issues we don't have bugs in bugzilla for, please file them separately.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.