All users were logged out of Bugzilla on October 13th, 2018

address bar is not focused after new tab command in fullscreen

VERIFIED FIXED in Firefox 3.7a1

Status

()

P2
minor
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: srbigode, Assigned: dao)

Tracking

({regression, verified1.9.1, verified1.9.2})

Trunk
Firefox 3.7a1
regression, verified1.9.1, verified1.9.2
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3.6 +
in-testsuite ?
in-litmus +

Firefox Tracking Flags

(status1.9.2 beta1-fixed, status1.9.1 .6-fixed)

Details

(Whiteboard: [fixed by bug 494373])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Missing feature from Firefox 2

Reproducible: Always

Steps to Reproduce:
1. Toggle Full Screen (F11)
2. Open a new Tab (Ctrl + T)
3. Type a url and press enter
Actual Results:  
Nothing Happens.

Expected Results:  
Opened the url.

On Firefox 2 (tested on Win32 and Ubuntu Linux) when you open a new tab in fullscreen the address bar is automatically focused, just like when not in fullscreen, even if it was "invisible". On Firefox 3 the focus only works when not in fullscreen.

So, for example, if I want to open delicious in a new tab (I use keywords on bookmarks) I will type:
On Firefox 2: (Ctrl + t) delicious (enter)
On Firefox 2 (Full Screen): (Ctrl + t) delicious (enter)
On Firefox 3: (Ctrl + t) delicious (enter)
On Firefox 3 (FS): (Ctrl + t) (Alt + d) delicious (enter)

I had always put the address on the side of the Alt Menu, on Firefox 2, saves a lot of screen space.
(Assignee)

Updated

11 years ago
Blocks: 240859
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Duplicate of this bug: 452367
OS: Windows XP → All
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Depends on: 450859

Comment 2

10 years ago
Same problem here.
It should be solved the same way as when you press ctrl+k or ctrl+l, that the address bar gets focus when you open up a new tab.

Updated

10 years ago
No longer depends on: 450859
Duplicate of this bug: 450859
(Assignee)

Updated

9 years ago
Depends on: 494373
(Assignee)

Updated

9 years ago
Assignee: nobody → dao
Whiteboard: [patch in bug 494373]

Comment 4

9 years ago
Bug 494373 has a patch, shouldn't this be a duplicate?
(Assignee)

Updated

9 years ago
Flags: blocking-firefox3.6?
Flags: blocking-firefox3.6? → blocking-firefox3.6+
Priority: -- → P2
Duplicate of this bug: 518808
Duplicate of this bug: 519123
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
status1.9.2: --- → beta1-fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
(Assignee)

Updated

9 years ago
status1.9.1: --- → .5-fixed
Verified fixed with builds on 1.9.1, 1.9.2, and trunk:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091108 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20091108045014

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b3pre) Gecko/20091112 Namoroka/3.6b3pre (.NET CLR 3.5.30729) ID:20091112051557

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6pre) Gecko/20091111 Shiretoko/3.5.6pre (.NET CLR 3.5.30729) ID:20091111044604

Would be great to have an automated test.
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Keywords: verified1.9.1, verified1.9.2
Hardware: x86 → All
Whiteboard: [patch in bug 494373] → [fixed by bug 494373]
Until we have an automated test this is covered by Litmus:
https://litmus.mozilla.org/show_test.cgi?id=9704
Flags: in-litmus-
Flags: in-litmus- → in-litmus+
(Assignee)

Updated

8 years ago
Duplicate of this bug: 459927
You need to log in before you can comment on or make changes to this bug.