Every three point sign (...) is replaced with a big fat pipe symbol (|), in the menus

VERIFIED DUPLICATE of bug 439730

Status

()

Firefox
Menus
VERIFIED DUPLICATE of bug 439730
10 years ago
9 years ago

People

(Reporter: Jan Diederich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008052906 Firefox/3.0

As you can see on the screenshot of the opened file menu, every entry which should end with 3 points (...) ends with a big fat vertical pipe symbol (|). This applies to all menu entries.

Reproducible: Always

Steps to Reproduce:
1. Open "Control Panel", "Appearance and Personalization", "Personalization", "Window Color and Appearance", at the bottom: "Open classic appearance properties for more color options".
2. Click on "Advanced".
3. Switch your Vista Menu Font to "MS Sans Serif".


Actual Results:  
Ugly menus, like described.

Expected Results:  
Good looking menus, like in every other SW. Firefox 2, Microsoft Office, Open Office, Visual Studio (in the latest _and_ prior version), Winrar,... and many many other programs, which had _never_ shown this behavior. There is only one program which messed its menus up: "Firefox 3"!

If you turn off "Smooth Edges of Screen Fonts" you can see why. --> The option can be found under "System Properties" | "Advanced" | "Performance Settings". So you can have a clear sharp font on your LCD-Monitor. The original Vista font is intentionally blurred to get a CRT like writing on a LCD (totally dumb, like applying scratch-noises to a CD to get the old platter feeling).

I know enough developers who turn this blur option off, because they are used to a clean and sharp font image - especially with their favorite font "Courier New". And if you switch the blur off, the new Vista font often shows up being totally unreadable in special contrasts, because it's totally optimized for that blur that makes it bolder.
(Reporter)

Comment 1

10 years ago
Forgot: It's the same with the status-bar: every information that should end with "..." ends with "|".
Your generated OS information isn't complete (better fix that too): it's an English Windows Vista with a German Firefox 3.0.
(Reporter)

Comment 2

10 years ago
Created attachment 325494 [details]
Screenshot of damaged File menu

Comment 3

10 years ago
Then use Tahoma, which is fine without ClearType.  MS Sans Serif is an old bitmap font and does not support special characters like the ellipses.  You can run the Windows Character Map and see the MS Sans Serif doesn't support symbols like that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439730

Comment 4

10 years ago
Also, as I noted in bug 439730, if you want the MS Sans Serif look without the obsolescence of MS Sans Serif, you really should be using Microsoft Sans Serif instead.
(Reporter)

Comment 5

10 years ago
(In reply to comment #3)
> Then use Tahoma, which is fine without ClearType.  MS Sans Serif is an old
> bitmap font and does not support special characters like the ellipses.  You can
> run the Windows Character Map and see the MS Sans Serif doesn't support symbols
> like that.

Oh my goodness, thanks! All the time I was living with an outdated bitmap font,
right under my nose. With totally narrow character support. But now I'm freed.
I never checked, but I would've run sooner or later in other problems, anyway.
Although, you should implement a warning, so Firefox informs the user if it
detects the outdated font. If you worry about performance, you could implement
it to only get checked on the first time Firefox starts up.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.