table with width of 100% inside a div with float:left does not expand to div width

RESOLVED DUPLICATE of bug 439843

Status

()

--
minor
RESOLVED DUPLICATE of bug 439843
11 years ago
11 years ago

People

(Reporter: jaoord, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9) Gecko/2008052906 Firefox/3.0

this code:

<div style="float:left">
<table style="width:100%">
...
</table>
</div>

results in a TABLE which is not fully expanded. Instead its width is about 70%. By removing the float:left the full width of the DIV is used


Reproducible: Always

Steps to Reproduce:
1. create the code like above
2. run it

Actual Results:  
not fully 100% wide table

Expected Results:  
table that fills the entire DIV

this odd behaviour can be fixed by removing float:left from the containing DIV
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.9.0 Branch

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439843
You need to log in before you can comment on or make changes to this bug.