printing an html webpage results invalid characters and corrupted content.

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: BobCaTT, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-AU; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-AU; rv:1.9) Gecko/2008052906 Firefox/3.0

After upgrading to FF3.0, I tried to print some webpages. Once out of the printer the pages were unreadable. Even spaces where replaces by some square characters.
I tried to use MS imaging printer, and I had the same result.

The print preview works fine.

Reproducible: Always

Steps to Reproduce:
1. open a web page 
2. print the page
3. read the page
Actual Results:  
Unreadable document

Expected Results:  
readable document

I've made a screen shot taken from Microsoft Imaging printer and attached it as a jpeg file. So have a look to this to understand the problem.
If someone need a paper scan of the result, please let me know.
(Reporter)

Comment 1

10 years ago
Created attachment 325510 [details]
Corrupted printed document.
Component: General → Printing
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → 1.9.0 Branch
Can't reproduce on:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I can't tell exactly which version you're dealing as the version says 1.9.0 branch but you're details say you're in 1.9?

So what are you using firefox 3 release or trunk build?
(Reporter)

Comment 3

10 years ago
Hi Natch,

The version of FF3.0 is the one I get during the download day. So, it's the official 3.0

I've talked to other people in my company who use the FF3.0 and they haven't seen this bug so far.

On my side what I will do is to delete my old FF2.0.0.14 profile to get a fresh one from FF3.0. I will do the same without any extension and after each extension installation. Just to be sure if there's no side effect / conflict with something like that.

If the profile is the answer, I will keep my old one for further analysis, just in case.

Do you also need more information ?

Thanks
(Reporter)

Comment 4

10 years ago
Hi Natch,

I've completly removed my old profile to force FF3 to create a new one.
I've reinstalled all my extensions as well, and everything is working fine.

If you wish, I have a backup of my old profile if you want to do more investigation on it.
(Reporter)

Comment 5

10 years ago
Hi,

One of my colleague has the same problem at the moment.
When printing some pages with FF3.0 (fr) do exactly the same result : Corrupted characters on paper.

I had a look to his add-ons list, only one (infoRSS) which I don't have. So you may exclude add-on problem.

we'll keep our profile for futur analysis, just in case.
(Reporter)

Comment 6

10 years ago
Hi There,

After cleaning my profile and adding some extension, I was working with mediawiki. For some dark reasons, the printing problem is here again. For what I see now, only some particular parts of the documents are affected by the bug, depending on the layout.

At the moment, for me, FF3.0 is not able to print at all as the final result is random.

I''m available with the FF team to provide any help or additionnal information.

Cheers
If the problem is extension related, and you are aware which particular extension it is, please alert them and give them any necessary information. If you can reproduce this bug with a clean profile http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
This sounds like a variant of bug 454532.
You need to log in before you can comment on or make changes to this bug.