Conflict between "closing multiple tabs" and "clear private data"

RESOLVED DUPLICATE of bug 398817

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 398817
10 years ago
10 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

This is not a bug per se but more of a conflict between preferences. Here it goes.

I have set FF to warn me when I'm closing a window with multiple tabs. When I tried to "save and quit" for the first time FF only showed a blank page after restart. I had a look around and found out that I also had selected "browsing history" under "always clear my private date on exit".

There should be a warning for this conflict or maybe you shouldn't have the option to use both at the same time.



Reproducible: Always

Steps to Reproduce:
1. Tools -> Options -> Tabs -> Warn me when closing multiple tabs
2. Tools -> Options -> Privacy -> Always clear my private data when I close FF (make sure you have selected "browsing history" in Settings for this)
3. Open multiple tabs
4. Select "save and quit" when asked
5. Restart FF
Actual Results:  
A blank page is loaded

Expected Results:  
Open my previous tabs.
(Reporter)

Updated

10 years ago
Severity: minor → normal
Version: unspecified → 3.0 Branch

Comment 1

10 years ago
Hopefully the UI will be cleaned up to be more user-friendly with this at some point, but the core complaint of logically conflicting prefs is a dupe of a WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398817
You need to log in before you can comment on or make changes to this bug.