Status

()

RESOLVED DUPLICATE of bug 432972
11 years ago
10 years ago

People

(Reporter: anikrandom8keudk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

In FF2: If you open the context menu on a link it will be aligned in such a way that the mouse cursor is placed at the very first item, which is "Open link in a new window".

In FF the context menu will be aligned in a different way, so that the mouse cursor is not pointing to the first item (open link in a new window).

Please check the images I have attached.

Reproducible: Always

Steps to Reproduce:
1. right click on link

Actual Results:  
Context menu is aligned in the middle.

Expected Results:  
Context menu should be aligned at the top.
(Reporter)

Comment 1

11 years ago
Created attachment 325521 [details]
this is how it shows up in ff2
(Reporter)

Comment 2

11 years ago
Created attachment 325522 [details]
this is how it shows up in ff3
(Reporter)

Comment 3

11 years ago
(OT: I have just realized that my email address is visible for everyone. How do I turn it off? (I've searched but didn't find an answer to this question, sorry))
(Reporter)

Comment 4

11 years ago
Actually I realized the wrong behaviour is a bit more complicated than I thought. Maybe these are two different issues:

What happens on my machine is that the context menu's x-position seem to be static, while the y-position is adjusted. However the y-position of the context menu is still not how I would expect it (not like in ff2)

Updated

11 years ago
Component: Menus → XP Toolkit/Widgets: Menus
Product: Firefox → Core
QA Contact: menus → xptoolkit.menus

Comment 5

11 years ago
First of all, everyone's email addresses are public here.  You can change it to something else, but then you won't be notified when changes are made to bugs.  Don't worry, I've not gotten any spam from here, personally.  (just occasionally a few idiots replying to me instead of the bug ;)

Sounds like an extension doing something stupid.

Please try in Firefox safe mode:
http://support.mozilla.com/en-US/kb/Safe+Mode
or possibly in a new profile:
http://support.mozilla.com/en-US/kb/Managing+Profiles

If it works correctly in safe mode, then it's caused by an add-on.  Disable them one at a time until you find the culprit.  After posting back here you'll have to report this issue to the extension's author to have it fixed.
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> First of all, everyone's email addresses are public here.  You can change it to
> something else, but then you won't be notified when changes are made to bugs. 
> Don't worry, I've not gotten any spam from here, personally.  (just
> occasionally a few idiots replying to me instead of the bug ;)

I find it a bit odd that the addresses are not hidden by default. Also it is surprising that you haven't gotten any spam mails yet since this is a public page and any spam harvester can check and collect the addresses on this page.


> Sounds like an extension doing something stupid.

Indeed, thanks for the pointers. It was a plugin which is not certified to work with 3.0 final, however a forced installation was possible but it seems to cause these side effects.

Thank you for your help. Can anyone (me?) close this bug or does this has to be done by some kind of moderator?

Comment 7

11 years ago
I'll close it now.  INVALID because it's not a Mozilla bug.

Please post the name of the plugin, in any case.  ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

11 years ago
The plugin is called "Snap Links":
https://addons.mozilla.org/en-US/firefox/addon/4336
(Reporter)

Comment 9

11 years ago
BTW, the actual bug seems to happen only if FF is not in maximized view, only then the menues are misaligned and pop up where they would pop up if FF was maximized.

Comment 10

11 years ago
(In reply to comment #8)
> The plugin is called "Snap Links":
> https://addons.mozilla.org/en-US/firefox/addon/4336
> 

In that case, I may as well dupe this.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 432972

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.menus → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.