CPU usage spikes when installing a xpi/extension/add-on

RESOLVED INCOMPLETE

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: Iuri Fiedoruk, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-03-15])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

When I try installing or upgrading a xpi in firefox3 on windows XP, cpu usages goes 99% and I have to kill firefox.
Tryied bfrom both addons page or the add-ons window in firefox.
Uninstalled firefox and removed everthing in application data.

Still same problem. I can't install a xpi :-(

But maybe it is a problem with extensions site?

Reproducible: Always

Steps to Reproduce:
1.try installing a xpi
2.
3.
Actual Results:  
CPU goes 99%, firefox just displays "connection" on add-ons window forever.

Expected Results:  
It should download the extension for install.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
Are you still seeing this? I am unable to reproduce this problem.
(Reporter)

Comment 2

9 years ago
Not as when extensions site where overloaded :)
But still happened some days ago when I tried to update better gmail from firefox (and not when starting it).
To reproduce, probably you could remove the network during the process of getting an extension, or something like that.
Could you provide actual steps you originally saw this with, the more precise the better. Were you installing from AMO or another site, Any particular add-on you can remember causing it.
(Reporter)

Comment 4

9 years ago
Created attachment 332341 [details]
You can see the bug here
(Reporter)

Comment 5

9 years ago
Comment on attachment 332341 [details]
You can see the bug here

><HTML><BODY><IMG height="384" width="512" src="http://protomank.googlepages.com/firefox_bug.png" alt="http://protomank.googlepages.com/firefox_bug.png" style="cursor: -moz-zoom-in;"/></BODY></HTML>
(Reporter)

Comment 6

9 years ago
Tools -> Extensions
Search for better gmail
Click Add to Firefox
*IF* the extensions site is overloaded, Firefox will do nothing - will not show the progress bar, just stays on the search screen "Connecting..."
Actually I just reproduced the issue twice when tring to install Gmail notifier, I'm providing a attached screenshot :-P
First time, I had to kill firefox, second time, got the screenshot and 20 seconds later, it seems to have stopped trying to get the extension and cpu usage returned to normal, but when I tryied to load a page... 99% CPU again.
(Reporter)

Comment 7

9 years ago
Comment on attachment 332341 [details]
You can see the bug here

<HTML><BODY><IMG src="http://protomank.googlepages.com/firefox_bug.png" alt="https://bugzilla.mozilla.org/attachment.cgi?id=332341" style="cursor: -moz-zoom-out;"/></BODY></HTML>
What makes you think this has to do with the extensions site being overloaded (it isn't overloaded right now). Given that you are seeing high CPU usages merely viewing pages I'm not sure that this is an add-ons manager specific issue.
(Reporter)

Comment 9

9 years ago
Because I only get high CPU usage AFTER an unsuccessful addon install.
I can see it with a empty firefox session also.
I got this EVERY single day when firefox 3.0 was launched, but with time, the problem started to fade.
I did a clean install of firefox, deleting my profile to see if the problem persisted, it did.
What kind of unsuccessful add-on installations are you getting?
(Reporter)

Comment 11

9 years ago
SImply put, when I try to install an addon and fails, I get 99% CPU usage.
If I try to load the url on a non-mozilla browser to download the XPI/JAR file, I get a network/site/etc timeout. Every single time mozilla addons site (releases.mozilla) is unresponsible, firefox looses itself and eat 99% cpu.

Actually I'm not able to load the site right now, and can reproduce the problem any time (I just tried to install and windows vista theme).
"when I try to install an addon and fails"

In what way does it fail, do you get some kind of error message? What method are you using to start the installation?
(Reporter)

Comment 13

9 years ago
Nops, no error, just keeps... doing nothing. When installed by the site, not even the loading spins. But then, it could be because the computer becomes a lot irresponsible because of firefox, so it cannot create another thread/process to show an error.
Can you give this a try in Firefox's safe mode so that we can check there is nothing odd caused by other extensions.

http://support.mozilla.com/en-US/kb/Safe+Mode

If that still shows the problem then try in a clean profile just to rule out anything odd in your current settings, you can switch back to your current profile afterwards.

http://support.mozilla.com/en-US/kb/Managing+profiles
Oh and do you have any anti-virus or firewall tools running, if so can you name them.
No response in two weeks and we need further details to diagnose this problem,
closing as incomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 17

9 years ago
Reopening the bug.
Not only I, but a colleague have this bug, both at work and at home.

@work: not32 and under a firewall I do not know because I'm not a TI guy
@home(me): avg and no firewall 
@home(friend): no anti-virus, no firewall

Again, it seems to happen when firefox can't connect to the addons site. Just happened again, when there was an extesion update.

Do not happens in Linux.
Happens both when installing or updating an extension.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 18

7 years ago
Iuri, have you seen this with any recent releases?
Whiteboard: [closeme 2011-03-15]
Version: unspecified → 1.9.0 Branch
(Reporter)

Comment 19

7 years ago
I'm not currently using Mozilla anymore, I'll just close the bug and hope it is vanished for good :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → INVALID
Resolution: INVALID → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.