Can't delete tags ("no title") with stuck, corrupted phantom bookmark

RESOLVED DUPLICATE of bug 429350

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 429350
10 years ago
10 years ago

People

(Reporter: lostatlantis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I couldn't find an exact match for my problem; bug #429350 seems closestly related.

Current situation - an undeletable "no title" tag listing with no associated bookmarks, and a phantom bookmark that if I delete and add back, the tags field is pre-filled with what I entered before.

It's a bit confusing, so below is what happened to trigger the bug:

1. added a new bookmark via Ctrl + D, adding tags "audio magazine" in the process
2. realizing I need a comma in between, corrected via bookmark manager
3. added tags to several existing bookmarks with "audio" as overlapping tag
4. noticed now there are TWO "audio" listings under tags - yes, SAME exact spelling, no spaces or anything else
5. tried to delete tags without success; tried to change that bookmark's tags manually, it's stuck; tried to right click on the first "audio" listing under tags and delete, nothing happens.
6. When I tried to import --> Restore, FF3 gives me an error message saying file not found, and poof my ENTIRE bookmarks set is wiped clean. Everything - toolbar, smart bookmarks, all gone.
7. Good thing I had backed up my old bookmarks into HTML - imported but Smart Bookmarks still M.I.A.
8. Googled and found this about:config --> browser.places.smartBookmarksVersion (set to 0)
9. It gets better - now if I try to bookmark that very first website - its tag field is AUTOMATICALLLY filled out with what I put in the very first time. I can't delete the freakin' tags.

10. So now, I decided to NOT bookmark that website, but I still have this "no title" tag listed, with NO bookmarks carrying it and no way to delete it.

Reproducible: Always

Steps to Reproduce:
1. Delete this phantom bookmark (bookmark deletes fine, but the "no title" tag remains)
2. Re-bookmark that same site - the tags field is now pre-filled with incorrect tags that I entered when I bookmarked it the very first time
3. Repeat to infinity
Actual Results:  
This particular bookmark's tag field seems stuck at read-only.  Also, the tags listing still shows this "no title" regardless if this bookmark is deleted or not.  

Expected Results:  
I should be able to edit the tags for this bookmark and have the changes stick.  Also, I should be able to delete this "no title" tag.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429350
You need to log in before you can comment on or make changes to this bug.