Closed Bug 44000 Opened 19 years ago Closed 19 years ago

:focus broken in <select> and input[type="text"]

Categories

(Core :: Layout: Form Controls, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: jameslariviere, Assigned: rods)

Details

(Keywords: testcase)

Attachments

(1 file)

DESCRIPTION:

:focus pseudo class rendering does not work for html form controls and makes 
forms unstable, sometimes crashing mozilla.

May be related to a bug I reported earlier, bug #41815, but more broadly.


STEPS TO REPRODUCE:

view test case.

ACTUAL RESULTS:

input[type="text"] and <select> does not render :focus correctly and the input
[type="text"] actually moves to the right a little.

Strangly though, the drop down part of the <select> renders the :focus 
correctly.

On larger forms than this test case, I have crashed mozilla switching between 
html form controls.


EXPECTED RESULTS:

all :focus parts should render like the drop down part of the combobox.

DOES NOT WORK CORRECTLY ON:

Win98 build 200062608 (6-26-00 nightly build)
Attached file test case
WTF on win98 2000072008; on select (focus) the background, text, and border
change color.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
Updating QA contact.
QA Contact: ckritzer → bsharma
Ian, after you choose an item in the <SELECT> in the testcase, the background 
is blue (or the standard syscolor you used for <select>'s), not orange. is this 
correct?
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101214 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.