Clicking the maximize button (the green plus) always expands window to maximum size

RESOLVED DUPLICATE of bug 232919

Status

()

Firefox
Shell Integration
--
minor
RESOLVED DUPLICATE of bug 232919
10 years ago
9 years ago

People

(Reporter: Todd Kennedy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

I have a dual monitor MacBook.  The external display (which is the primary display when connected) is a larger resolution than the MacBook built-in.  Firefox, when open on the main screen takes up more real estate than the built-in monitor.

When I disconnect the external screen and click the maximize button (the green plus in the OS chrome), it resizes to fit the laptop monitor.

When I plug the external back in, and press the green button, it expands to the entire external monitor.

What should happen is that the browser is already in the "maximized" state and when I push the maximize button when the browser is back on the external monitor, it should revert to its old dimentions.

Reproducible: Always

Steps to Reproduce:
1. Plug in external monitor with a higher resolution than the built in monitor (or just two monitors, one with a larger resolution).  The larger resolution monitor should be configured as the main screen (the one with the menu bar and dock)
2. Adjust firefox so that it is on the larger resolution screen with the chrome taking up more space than is available on the smaller resolution screen.
3. Unplug the larger screen, reverting the mac to a single screen machine and click the "maximize" button (green plus) in the chrome.  Browser window should take up the maximum amount of screen real-estate
4. Plug in external monitor and let browser re-appear on that screen
5. Click maximize again.
Actual Results:  
When you perform step 5 the browser takes the maximum amount of space on the screen.  

Expected Results:  
Should revert to previous view window size (as it was in step 2) since even though the larger resolution monitor has more space available, browser is already in "maximized" state

The correct behavior is observable in Firefox 2.0.0.11 (as well as tons of other various mac apps)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 232919
You need to log in before you can comment on or make changes to this bug.