Download Manager causes firefox to hangs with 'Save As' option.

UNCONFIRMED
Unassigned

Status

()

Toolkit
Downloads API
UNCONFIRMED
10 years ago
5 years ago

People

(Reporter: Matthew Nelson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Download manager causes firefox to hang when you attempt to use 'Save As' from the context menu then press 'Save' or 'Cancel'. It hangs for 30 secs to 1 min. Works with various files, sites, and content.

Reproducible: Sometimes

Steps to Reproduce:
1. Right-Clicking file and 'Save As'
2. Click Cancel
3. Or Click Save
Actual Results:  
Firefox will hang for 30 secs to 1 min not allowing the user to close download manager or firefox, Cannot open new tabs or browser.

Expected Results:  
Closed download manager without hanging or continue to download content/file

Attempted with 3 computer all with Windows XP, 2 with SP3 and 1 with SP2
Did you try it in safe mode http://kb.mozillazine.org/Safe_Mode_(Firefox)
(Reporter)

Comment 2

10 years ago
I have not, I'll test it in the next few hours. Since it only happens 1/5 downloads. I have disabled addons/themes.
(Reporter)

Comment 3

10 years ago
I just ran about 6 hours of safe mode and it did catch up at least 2 times out of 20 downloads. It's not entirely important. But just kind of a minor glitch. I tried various sites such as: download.com, filefront.com, fileplanet.com, dl.tv, revision3.com, hak5.org, etc.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 4

5 years ago
For me this is new as of FF 19.0.2 and persists across Aurora 21.0.a2.  I have to date:
1) Restarted in Safe Mode
2) Removed ALL extensions
3) Cleared all history (forever)
4) Tried saving with a new profile
5) Disabled virus scanning in about:config (despite the fact that I have no virus scanner)
6) Logged out of KDE and logged back in.

Steps to reproduce are the same as the initial poster.

This is occurring on an HP Pavilion dv6-3010us (dual core AMD Turion II P520) with Vector Linux 7.0 (Slackware-based) operating system kernel 3.2.6, and KDE 4.8.3.

It's quite annoying and new.  I'm an extension developer who uses FF for quite a lot of scientific type programming, and for me, this is very nearly a show stopper for casual browsing.

Comment 5

5 years ago
OK... I looked at what other packages I installed near the time 19.0.2 came out.  I removed gtk+3 and rebooted.  The slowdown is gone.  Perhaps there are some issues with gtk+3 compared to gtk+2 on linux?  Anyhow, thanks for listening... :-)
You need to log in before you can comment on or make changes to this bug.