Saved tabs not restored when clear private data on exit is flagged and Firefox closed via the X button

RESOLVED DUPLICATE of bug 398817

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 398817
10 years ago
9 years ago

People

(Reporter: Nick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

If the privacy setting to clear browser history on exit is flagged, then when multiple tabs are open and the user clicks the "X" button to close Firefox (not File->Exit) and then chooses to "Save and Quit," then the tabs are not restored when Firefox is restarted. Only a blank tab is show when Firefox is restarted (the home page is not shown either).

This only happens when clicking the X button, File->Exit works properly.

Reproducible: Always

Steps to Reproduce:
1. Turn on option to clear private data on close (clear browser history, doesn't matter if it is prompted or not)
2. Turn on option to prompt for Save and Quit
3. Open multiple tabs
4. Click the X button to close Firefox (not File->Exit)
5. Choose to Save and Quit on the prompt
6. Launch Firefox again
Actual Results:  
Saved tabs are not restored, only a blank tab is shown.

Expected Results:  
All tabs that were open when closing should be restored (Same behavior as File->Exit).
Dupe of bug # 439892? (wasn't confirmed yet, but dupe nonetheless)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398817
You need to log in before you can comment on or make changes to this bug.