Allow selection of multiple bookmarks/folders in left pane of Organize Bookmarks dialog

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
10 years ago
a year ago

People

(Reporter: David Reitter, Unassigned)

Tracking

(Blocks: 1 bug)

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

In the Bookmark "Library" (Bookmarks -> organize), I cannot select multiple folders using Shift or Apple mouse clicks.

This is actually important when you want to move a number of folders out of a "From Safari" folder that is created during import.  I can't see how else to do this but to select and drag&drop every single folder.  No good.  

I thought such stuff comes for free when using standard Cocoa controls.  Or aren't you using the system's UI toolkit??

Reproducible: Always

Steps to Reproduce:
should be clear
Actual Results:  
only the folder that I click on is selected, other folders are de-selected.

Expected Results:  
multiple folder selection!
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Shift-select and Command-select (aka Apple-select) both work fine for
me (in the right-hand pane of the Organize Bookmarks dialog).
(Reporter)

Comment 2

10 years ago
They work fine for me too in the right-hand pane, but not in the left-hand one.

That's a viable workaround for this bug, but intuitively, I tried to move things around within the left pane and that should be supported.
Safari has a very similar dialog for organizing bookmarks (Bookmarks :
Show All Bookmarks), and it works the same way (shift-select and
command-select only work in the right pane).

Firefox's Organize Bookmarks dialog works the same way on Windows and
Linux (shift-select and ctrl-select only work in the right pane).

This isn't a bug.

In effect you're requesting a new feature ... but I think it's very
unlikely that your request will be granted.
Severity: normal → enhancement
Summary: Cannot select multiple bookmark folders → Allow selection of multiple bookmarks/folders in left pane of Organize Bookmarks dialog

Comment 4

10 years ago
This request is like asking MS to modify Windows Explorer or Apple to modify the Finder. I think it should be closed as expected behaviour.
Peter van der Woude in his comment on bug 263261 "the left pane is only for navigation"
and ctalbert on irc agreed with me.
Closing now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
It is a perfectly valid request to make. It is up to the module owners to decide whether to implement or WONTFIX this issue.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

10 years ago
I agree that this problem should be fixed; it is counterintuitive. I believe this is a regression from Firefox 2.

Comment 7

9 years ago
For Windows same behavior  for Library listing.

Multiple selection was available in both left and right  panes of the Library List  in Firefox 2,  and only available in right  pane in Firefox 3.

This digresses from normal behavior of sidebars for both History and Bookmarks in Firefox 3, where multiple selection at left of favicons to allow for copying/moving/delete, so is certainly counterintuive and a digression from Firefox 2.   (Found this bug because can't use multiple selection in drop-down bookmarks in Fx2 or Fx3.)

You should be able to click at the left of the favicon to make initial selection and expand with  Shift+Click  or include discontiguous  additional selection(s) with Cmd/Ctrl+click and extend discontigous addition with Cmd/Ctrl+Shift+click     as in bookmark and history sidebars.
and, what do we show in the right pane if you select more containers in the left one?

Updated

9 years ago
Whiteboard: wontfix?

Comment 9

9 years ago
Regards Comment #8.   The selection on the right should change according to the first (top-most item) selected as it had done in Firefox 2.  Typically a person makes selections down from the first on the left side so typically would see no change after the first selection.   

Nothing happens with bookmarks until an action is taken and typically that action would be Delete, Copy, Cut, Move through clip board or by dragging.  You cannot drag from the left side to right side so the right side display has very little significance to actual changes other than display of top-most in selection when multiple selections are being built.  Use of the clipboard or dragging to the bookmarks toolbar or to something on the left side display is normal and permitted.   All of this was available in version 2.

Comment 10

9 years ago
Also regards Comment #8.  Firefox 3 also introduced arrowpoints instead of less ambiguous [-] and [+] symbols to collapse or expand a folder, and in Firefox 3 the  right pane folders can not be expanded, which is possibly what created this mess in the first place.  BTW I am on Windows so problems are not restricted to Mac.

Comment 11

6 years ago
The same applies for the bookmark sidebar. There you also cannot select multiple items. 

I might create an addon to implement this feature (at least for the sidebar). Anybody here, who could give me hint, how this can be accomplished in the easiest way? (I have created a few Thunderbird addons, but no for Firefox) Do I have to change the seltype of the tree? Where is it set in Firefox to single? Is it?

Thank you.
(In reply to Joachim Herb from comment #11)
> The same applies for the bookmark sidebar. There you also cannot select
> multiple items. 

did you try to click on the empty space to the left of the icon?

Comment 13

6 years ago
(In reply to Marco Bonardo [:mak] from comment #12)
> (In reply to Joachim Herb from comment #11)
> > The same applies for the bookmark sidebar. There you also cannot select
> > multiple items. 
> 
> did you try to click on the empty space to the left of the icon?

Thank you for this tip.
Not going to do this since the most common behavior across OS is to allow multiple selection only in the right pane, while the left pane works like sort of a media library giving you a quick link to categories.
Adding multiple selection would introduce troubles both to figure out what's the right purpose in the right pane and to properly manage multiple selections across different kind of content (like I may select Today, Downloads, a tag container and a bookmark folder).
So in the end the benefit is unclear, but the development cost is clearly high.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago5 years ago
Resolution: --- → WONTFIX
Whiteboard: wontfix?

Updated

a year ago
Blocks: 1320731
You need to log in before you can comment on or make changes to this bug.