Skype Firefox extension breaks Google maps

RESOLVED INVALID

Status

()

defect
--
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: tony, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

Simply try the above link and you'll notice that google maps won't load.
Looks like a javascript bug ....nonetheless it was working with firefox 2 before I upgraded.


Reproducible: Always

Steps to Reproduce:
1.http://maps.google.com.au/maps?hl=en&tab=wl
2.
3.
Works fine for me.  (3.0 on Linux)

Give Firefox safe mode a try:
http://support.mozilla.com/en-US/kb/Safe+Mode

You can also try things in a new profile:
http://support.mozilla.com/en-US/kb/Managing+profiles
Hi Dave,
but have you tried on Windows?
Thanks
Just pulled up Windows XP SP3 in a VirtualBox and installed Firefox 3.0.  Works fine there too.

Please test without extensions.

There's also the possibility that we're served different pages due to our locations, and the server you're connecting to has issues currently.  In any case, I get no problems with your STR here.
Having same problem loading Google maps with Firefox 3.0. Had no problems running 2.0. Operating under Windows XP Professional.
I had the same problem. By using the Safe Mode option I narrowed down the problem to the Skype extension for Firefox. Here are some details:

System:
Windows XP SP 3
Firefox 3 (gold version)

Extensions:
Evernote Web Clipper v. 3.0.0.122
Piclens 1.7.0.3459
Skype Extension for Firefox 2.2.0.87
Stumbleupon 3.23

How to reproduce:
Download an install Skype extensions. Enable the extension and go to the basic Google Map page. The map should NOT load. Disable the extension and try again. Now the map should load.

Hope that helps.
Confirmed.  Installed Skype 3.8 which auto-installed Skype Extension for Firefox 2.2.0.87 in a Windows XP SP3 VirtualBox and it breaks maps.google.com.  Disabling the extension fixes things.

You'll need to report this to the authors, as it is not a Mozilla product.  Closing as INVALID as a result.

If you're curious, do a search here for all open and closed bugs about Skype.  It seems to cause a lot of problems.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
Summary: Google maps doesn't load → Skype Firefox extension breaks Google maps
Version: unspecified → 3.0 Branch
Duplicate of this bug: 443362
Bug details passed along to Skype support on 6/30/2008. 

Skype support responded to bug report on 7/06/2008. They confirmed the bug and noted that the problem was fixed in the latest hotfix available for download and installation from the following URL:

https://developer.skype.com/SkypeToolbars?action=AttachFile&do=get&target=SkypeFFPlugin.2.2.0.90.exe

I have applied the above hotfix and found that it does in fact fix the problem.
You need to log in before you can comment on or make changes to this bug.