Closed Bug 440198 Opened 11 years ago Closed 8 years ago

If Firefox must scroll the page to display a search result, centre them vertically to the page

Categories

(Toolkit :: Find Toolbar, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 171237

People

(Reporter: cjcypoi02, Unassigned)

References

Details

(Keywords: polish, ue, Whiteboard: [parity-Opera] [parity-Safari])

Attachments

(1 file)

I don't know if this bug can be applied to other Mozilla product. If yes, please change Product and Component to Core - Search.


Currently Firefox when display a search result scrolls the page less than possible, so the result will be displayed at the bottom or at the top of the page. This is the same behaviour of IE.
This is sometimes problematic, because you could want to see a piece of text after/before the line of displayed result.

I propose to add the ability to centre the displayed search result as much as possible if the page must scroll, as Safari and Opera do.

IMO this should be the default behaviour, but also a simple option to enable it will be good.
Whiteboard: [parity-Opera] [parity-Safari]
Component: Search → Find Toolbar / FastFind
QA Contact: search → fast.find
Please search before you file a bug. Searching for 'search center' immediately found a few.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 171237
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
I'm unduping this as the duplicate has been moved to Seamonkey and the implementations for this feature have diverged from what I've been told in #developers.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
FYI this bug is referenced as the 'upstream' bug behind Ubuntu bug https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/534606

It's a little different, though; a fixed-position object completely obscures the search-match text so that it is invisible to the user.

Please see the demo html file attached to the referenced Ubuntu bug.
Duplicate of this bug: 455446
Depends on: 171237
Duplicate of this bug: 587314
Duplicate of this bug: 629317
Duplicate of this bug: 651128
Duplicate of this bug: 713459
I've uploaded a comparison between Safari and Firefox.

In few words, there're lots of work to do here.

Safari :
- Grey overlay in order not to focus on the page
- Bubble animation to see where the word is
- Pretty beautiful background on the searched word
- Indication where other searched words are
- Center the screen with like padding-top and padding-bottom as 25px from the screen

In other words, what safari does is perfect.

The thing to do at least is to add padding when centering about the search word, because at the current time, the searched word is sticked to the screen corner and it ain't really pratical.
I hope Mozilla wont be violating any of Apple's stupid patents implementing these ideas.
To be clear, I'm not saying Mozilla should do like Apple but yeah I find their way really great.
Status: REOPENED → RESOLVED
Closed: 11 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 171237
You need to log in before you can comment on or make changes to this bug.