gmail chat disconnects on pressing esc key to close chat window

RESOLVED DUPLICATE of bug 435611

Status

()

RESOLVED DUPLICATE of bug 435611
11 years ago
10 years ago

People

(Reporter: pvineet, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The gmail chat disconnects on pressing esc key to close an ongoing chat. The chat window is closed but the gmail chat disconnects after some time. The reconnection timer is seen. Similar problem is not seen with IE

Reproducible: Always

Steps to Reproduce:
1.logon to gmail
2.open some chat windows(2-3)
3.close them by pressing esc key
4.wait for some time / repeat the process 
Actual Results:  
The gmail chat disconnects

Expected Results:  
The gmail chat should not disconnect
(Reporter)

Updated

11 years ago
Version: unspecified → 3.0 Branch
It only happens for me when I click the Esc button very quickly and repeatedly, which makes sense because it doesn't give the app a chance to recapture the key and is thus sent to the browser, which stops Ajax, hence momentarily disabling Chat.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 435611
You need to log in before you can comment on or make changes to this bug.