Upgrading from 2.x forgets download location

VERIFIED INVALID

Status

()

Toolkit
Downloads API
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Peter G., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT5 6.0; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

I upgraded from 2.0.0.14 if I remember well to the latest version 3.0 and had to notice that even though every setting the old version had was migrated and set by the upgrade installation the download location was not remembered and had changed back to "Documents" while I had it set for "Desktop".

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.



It should have remembered what my download settings were.

Comment 1

10 years ago
Works for me, Firefox 2.0.0.14 profile migrated to 3.0 on Linux.
Just tested this myself on Vista and got the same results as Mats in comment 1; are you sure you didn't/aren't:

A) Create a new profile later on or accidentally change the location
B) Using any add-ons?
(Reporter)

Comment 3

10 years ago
I only have the Download Statusbar addon installed. Did have a couple others but those were disabled due to incompatibility. I'm pretty sure I didn't accidentally changed the location since I only entered the settings page when I noticed my downloads weren't in the usual folder (Desktop).

Comment 4

10 years ago
> had changed back to "Documents" while I had it set for "Desktop".

Are you sure it was "Documents" and not "Downloads"? In some cases on Vista installs the default folder will be set to the default Vista downloads location depending on certain pref settings.
(Reporter)

Comment 5

10 years ago
You're right Jim, it was Downloads and not Document. My bad.

Pete

Comment 6

10 years ago
Ok, that might anoy some folks but it was a decision that was made for better vista compatability. I'll keep an eye on the thread and lets see how many compaints we get.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Verified
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.