If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

keep history of bookmarks

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: anselm meyer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9) Gecko/2008052906 Firefox/3.0

keep history of bookmarks. this would allow finding bookmarks 
that have been deleted but turn out to be interesting later on.
this backup would also make cleaning out old bookmarks easier 
psychologically because the user always knows, despite deleting 
something, if he/she needs the bookmark later on, then it will 
be found in bookmarks history.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
If you delete the bookmark, but it's kept in a bookmark history list, then it's not really deleted is it? So why not simply not delete the bookmark in the first place, or move it to a folder called "Bookmarks I Don't Want Anymore But Might Do In The Future"?
(Reporter)

Comment 2

9 years ago
The function as requested is especially usefull for people with many bookmarks.
if you would manually move bookmarks to an "unused" folder, then you would have to keep sub-folders in there aswell so old bookmarks are still categorized. Otherwise it would get problematic finding anything.

Your proposal is a usable workaround.

My original proposal was intended as something that can increase ease of use and make it easier to clean up your bookmarks (because you know, nothing is lost should you want to use any old bookmarks again).
I think it would make sense the way I proposed it. Not a killer-feature but it would be really helpfull to avoid overcrowded bookmarks-collections.

This proposal, frankly, doesn't make sense.  Delete, but not really delete, is unintuitive and would be confusing to users.

There's an Unsorted Bookmarks list that isn't exposed in the UI, if your goal is to have a clean UI.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

9 years ago
Moving bookmarks to an unsorted folder means loosing the context of categories (-> where the bookmark was filed).
It`s extra-work to retrieve an old bookmark back to its original place. 

No big deal.

It would make as much sense though as any history function in any program.
You delete it and don`t see it anymore.
But if you should later on think there was a site you had bookmarked that had information on it that now seems interesting, you can select history from the bookmarks organizer and can browse everything you once had bookmared.
I don`t see how this is going to be confusing. 

You need to log in before you can comment on or make changes to this bug.