'Save and Quit' Function opens blank window if 'always clear my private data' option is selected

RESOLVED DUPLICATE of bug 398817

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 398817
10 years ago
10 years ago

People

(Reporter: Lucienp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Selecting the Save and Quit option when closing the (final - see https://bugzilla.mozilla.org/show_bug.cgi?id=385794) window with multiple tabs, closes the program, but does NOT actually save the data.  When reopening, Firefox opens with a blank window, not the saved tabs, and not with the normal 'Home' page.

 

Reproducible: Always

Steps to Reproduce:
1.  Enable 'Always clear my private data' in options
2.  Open multiple tabs in a (single) window
3.  Close the window
4.  Re-start FF3
5.  Blank Window opens
Actual Results:  
Blank window opens

Expected Results:  
should save the final window/tab information EVEN IF 'always clear' option is selected, but not the history, tokens, cookies, etc.

Comment 1

10 years ago
duplicate of 439802

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398817
You need to log in before you can comment on or make changes to this bug.